aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-orangepi-zero
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2018-01-01 09:56:12 +0000
committerKevin Lo <kevlo@FreeBSD.org>2018-01-01 09:56:12 +0000
commita01f58c46350ce12014620382d7657b4112105c9 (patch)
treee05a1ea9a139a7ea6fec7910f3fef185aa17afdb /sysutils/u-boot-orangepi-zero
parentaa1109c93761447b9e21dffcab72566b18a70b3e (diff)
downloadports-a01f58c46350ce12014620382d7657b4112105c9.tar.gz
ports-a01f58c46350ce12014620382d7657b4112105c9.zip
Add slave port for OrangePi Zero ARM SoC board u-boot support.
Notes
Notes: svn path=/head/; revision=457761
Diffstat (limited to 'sysutils/u-boot-orangepi-zero')
-rw-r--r--sysutils/u-boot-orangepi-zero/Makefile10
-rw-r--r--sysutils/u-boot-orangepi-zero/pkg-descr19
2 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/u-boot-orangepi-zero/Makefile b/sysutils/u-boot-orangepi-zero/Makefile
new file mode 100644
index 000000000000..b46ee1b836c8
--- /dev/null
+++ b/sysutils/u-boot-orangepi-zero/Makefile
@@ -0,0 +1,10 @@
+# $FreeBSD$
+
+MAINTAINER= kevlo@FreeBSD.org
+MASTERDIR= ${.CURDIR}/../u-boot-master
+
+MODEL= orangepi-zero
+BOARD_CONFIG= orangepi_zero_defconfig
+FAMILY= allwinner
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-orangepi-zero/pkg-descr b/sysutils/u-boot-orangepi-zero/pkg-descr
new file mode 100644
index 000000000000..0d85d15bd54a
--- /dev/null
+++ b/sysutils/u-boot-orangepi-zero/pkg-descr
@@ -0,0 +1,19 @@
+U-Boot loader for OrangePi Zero.
+
+To install this bootloader on an sdcard just do :
+dd if=/usr/local/share/u-boot/u-boot-orangepi-zero/u-boot-sunxi-with-spl.bin of=/path/to/sdcarddevice bs=1k seek=8 conv=notrunc,sync
+
+This version is patched so that:
+ * ELF and API features are enabled.
+ * The default environment is trimmed to just what's needed to boot.
+ * The saveenv command writes to the file u-boot.env on the FAT partition.
+ * The DTB file name is chosen based on the board model and passed to ubldr.bin
+ using the fdtfile env variable. ubldr.bin loads the DTB from /boot/dtb/ on
+ the FreeBSD partition.
+ * By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition
+ to address 0x42000000, and launches it.
+
+For information about running FreeBSD on Allwinner boards, see
+ https://wiki.freebsd.org/FreeBSD/arm/Allwinner
+
+For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot