aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-pandaboard
diff options
context:
space:
mode:
authorIan Lepore <ian@FreeBSD.org>2015-08-09 01:47:54 +0000
committerIan Lepore <ian@FreeBSD.org>2015-08-09 01:47:54 +0000
commit05abf7c1a3ec6b73db0891cd9e9634fd0bedf761 (patch)
treec4fe10da9f571dcb81708156daac2024e2910528 /sysutils/u-boot-pandaboard
parent6324336f700046833987f87ba3fbf951791d2228 (diff)
downloadports-05abf7c1a3ec6b73db0891cd9e9634fd0bedf761.tar.gz
ports-05abf7c1a3ec6b73db0891cd9e9634fd0bedf761.zip
Use gcc 4.9.2 to cross-compile u-boot for pandaboard.
Approved by: rpaulo
Notes
Notes: svn path=/head/; revision=393755
Diffstat (limited to 'sysutils/u-boot-pandaboard')
-rw-r--r--sysutils/u-boot-pandaboard/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/sysutils/u-boot-pandaboard/Makefile b/sysutils/u-boot-pandaboard/Makefile
index f7a1fd427280..28a03a737b53 100644
--- a/sysutils/u-boot-pandaboard/Makefile
+++ b/sysutils/u-boot-pandaboard/Makefile
@@ -11,7 +11,9 @@ COMMENT= Cross-build U-Boot loader for PandaBoard
LICENSE= GPLv2
-BUILD_DEPENDS= arm-none-eabi-gcc:${PORTSDIR}/devel/arm-none-eabi-gcc
+BUILD_DEPENDS= ${CROSS_GCC}:${PORTSDIR}/devel/arm-none-eabi-gcc492
+
+CROSS_GCC= arm-none-eabi-gcc-4.9.2
NO_ARCH= yes
@@ -25,6 +27,7 @@ PLIST_FILES= ${U_BOOT_DIR}/u-boot.img \
${U_BOOT_DIR}/README
MAKE_ARGS+= ARCH=arm \
+ CC=${CROSS_GCC} \
CROSS_COMPILE=arm-none-eabi-
do-configure: