aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-rpi
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-07-24 09:48:39 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-07-24 09:48:39 +0000
commitd9ed9ba7944b0be27789992d2e53e05affdeca1b (patch)
tree29849d962cc8263423c3d66cdfae19ed5f358e51 /sysutils/u-boot-rpi
parentafe2e12dfa24cc7d7b270d0b569b647072d19705 (diff)
downloadports-d9ed9ba7944b0be27789992d2e53e05affdeca1b.tar.gz
ports-d9ed9ba7944b0be27789992d2e53e05affdeca1b.zip
Fix few style violations in u-boot ports:
- GMAKE -> MAKE_CMD, MAKE_CMD is always set to required make implementation - CP -> INSTALL_DATA, INSTALL_DATA makes sure files are always installed with proper permissions - sysutils/u-boot-rpi: include missed files installed in STAGEDIR in PLIST_FILES PR: 210982 Submitted by: myself Approved by: maintainers timeout
Notes
Notes: svn path=/head/; revision=418996
Diffstat (limited to 'sysutils/u-boot-rpi')
-rw-r--r--sysutils/u-boot-rpi/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/sysutils/u-boot-rpi/Makefile b/sysutils/u-boot-rpi/Makefile
index 05256bd0e176..aa1530b5f88f 100644
--- a/sysutils/u-boot-rpi/Makefile
+++ b/sysutils/u-boot-rpi/Makefile
@@ -2,6 +2,7 @@
PORTNAME= u-boot
PORTVERSION= 2016.01
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.denx.de/pub/u-boot/ \
LOCAL/ian/:bootfiles
@@ -31,6 +32,8 @@ PLIST_FILES= ${U_BOOT_DIR}/u-boot.img \
${U_BOOT_DIR}/config.txt \
${U_BOOT_DIR}/fixup.dat \
${U_BOOT_DIR}/fixup_cd.dat \
+ ${U_BOOT_DIR}/fixup_db.dat \
+ ${U_BOOT_DIR}/fixup_x.dat \
${U_BOOT_DIR}/start.elf \
${U_BOOT_DIR}/start_cd.elf
@@ -38,7 +41,7 @@ MAKE_ARGS+= ARCH=arm \
CROSS_COMPILE=arm-none-eabi-
do-configure:
- (cd ${WRKSRC}; ${GMAKE} rpi_defconfig)
+ (cd ${WRKSRC}; ${MAKE_CMD} rpi_defconfig)
# The output of the u-boot build process is u-boot.bin. We have to put a
# standard (for the RPi) image header on the front of it, and the resulting
@@ -49,6 +52,6 @@ do-install:
${MKDIR} ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
${GZCAT} ${FILESDIR}/imgprefix.bin.gz >${IMGFILE}
${CAT} ${WRKSRC}/u-boot.bin >>${IMGFILE}
- ${CP} ${WRK_BOOTFILES}/* ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}/
+ ${INSTALL_DATA} ${WRK_BOOTFILES}/* ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
.include <bsd.port.mk>