aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ua
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2014-04-01 18:02:30 +0000
committerChris Rees <crees@FreeBSD.org>2014-04-01 18:02:30 +0000
commit0ffc96fc1557557f6444402499e81971a0d77f7f (patch)
treefb872b7008881d715d0998647d5c766911c51d90 /sysutils/ua
parent7c3969f3b8e2b80ae7424e77e661dbe7015c153f (diff)
downloadports-0ffc96fc1557557f6444402499e81971a0d77f7f.tar.gz
ports-0ffc96fc1557557f6444402499e81971a0d77f7f.zip
Fix build with modern c++
Finish staging ;)
Notes
Notes: svn path=/head/; revision=349870
Diffstat (limited to 'sysutils/ua')
-rw-r--r--sysutils/ua/Makefile13
-rw-r--r--sysutils/ua/files/patch-kua.cc10
-rw-r--r--sysutils/ua/files/patch-ua.cc10
3 files changed, 21 insertions, 12 deletions
diff --git a/sysutils/ua/Makefile b/sysutils/ua/Makefile
index 96a40f6ee6d0..850b8e0ded57 100644
--- a/sysutils/ua/Makefile
+++ b/sysutils/ua/Makefile
@@ -14,25 +14,14 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/kua bin/ua \
man/man1/kua.1.gz man/man1/ua.1.gz
PORTDOCS= README
-MAN1L= kua.1 ua.1
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${OSVERSION} > 1000000
-.if ${CC} != gcc42
-BROKEN= needs gcc4.2 to compile
-.endif
-.endif
-
post-install:
-.for i in ${MAN1L}
- ${INSTALL_MAN} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/man/man1/
-.endfor
-.if ${PORT_OPTIONS:MDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/*.1 ${STAGEDIR}${PREFIX}/man/man1/
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
-.endif
.include <bsd.port.mk>
diff --git a/sysutils/ua/files/patch-kua.cc b/sysutils/ua/files/patch-kua.cc
new file mode 100644
index 000000000000..b3b22ae1b7c2
--- /dev/null
+++ b/sysutils/ua/files/patch-kua.cc
@@ -0,0 +1,10 @@
+--- ./kua.cc.orig 2014-03-31 20:20:29.908846067 +0100
++++ ./kua.cc 2014-03-31 20:20:48.178847931 +0100
+@@ -49,6 +49,7 @@
+
+ extern "C" {
+ #include <stdio.h>
++#include <unistd.h>
+ }
+
+ static char __help[] =
diff --git a/sysutils/ua/files/patch-ua.cc b/sysutils/ua/files/patch-ua.cc
new file mode 100644
index 000000000000..2c78cb9d7552
--- /dev/null
+++ b/sysutils/ua/files/patch-ua.cc
@@ -0,0 +1,10 @@
+--- ./ua.cc.orig 2014-03-31 20:20:23.870845476 +0100
++++ ./ua.cc 2014-03-31 20:21:00.021844495 +0100
+@@ -57,6 +57,7 @@
+
+ extern "C" {
+ #include <stdio.h>
++#include <unistd.h>
+ }
+
+ static char __help[] =