aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ufs_copy
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2020-07-04 15:37:13 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2020-07-04 15:37:13 +0000
commit5aba6458f6aea471bc704c172e3f36bab70bb4b3 (patch)
tree582580ca15d595a2e8194b3519c3908c4de66d6f /sysutils/ufs_copy
parenta6677396ff0fc37ab8968abdcc9df23716cdb38b (diff)
downloadports-5aba6458f6aea471bc704c172e3f36bab70bb4b3.tar.gz
ports-5aba6458f6aea471bc704c172e3f36bab70bb4b3.zip
- Fix build error on -current.
- Use PLIST_FILES instead of pkg-plist.
Notes
Notes: svn path=/head/; revision=541219
Diffstat (limited to 'sysutils/ufs_copy')
-rw-r--r--sysutils/ufs_copy/Makefile2
-rw-r--r--sysutils/ufs_copy/files/patch-ufs_copy.c6
-rw-r--r--sysutils/ufs_copy/pkg-plist1
3 files changed, 7 insertions, 2 deletions
diff --git a/sysutils/ufs_copy/Makefile b/sysutils/ufs_copy/Makefile
index 4deec78f22e9..b021c707a684 100644
--- a/sysutils/ufs_copy/Makefile
+++ b/sysutils/ufs_copy/Makefile
@@ -21,6 +21,8 @@ PORTDOCS= README
OPTIONS_DEFINE= DOCS
+PLIST_FILES= sbin/ufs_copy
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/sysutils/ufs_copy/files/patch-ufs_copy.c b/sysutils/ufs_copy/files/patch-ufs_copy.c
index fe0ac7ef627d..3c5bfd367a81 100644
--- a/sysutils/ufs_copy/files/patch-ufs_copy.c
+++ b/sysutils/ufs_copy/files/patch-ufs_copy.c
@@ -58,11 +58,15 @@
fprintf(stderr, "done\n");
else
fprintf(stderr, "failed\n");
-@@ -262,6 +289,7 @@ copy_ufs(const char *src_path, const cha
+@@ -262,6 +289,11 @@ copy_ufs(const char *src_path, const char *dst_path)
}
}
bcopy(&src, &dst, sizeof(dst));
++#if (defined(__FreeBSD_version) && __FreeBSD_version >= 1300100)
++ dst.d_si = NULL;
++#else
+ dst.d_sbcsum = NULL;
++#endif
dst.d_name = dst_path;
dst.d_fd = open(dst_path, O_CREAT | O_WRONLY, S_IRUSR | S_IWUSR );
if (dst.d_fd < 0) {
diff --git a/sysutils/ufs_copy/pkg-plist b/sysutils/ufs_copy/pkg-plist
deleted file mode 100644
index d2828d73ab27..000000000000
--- a/sysutils/ufs_copy/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-sbin/ufs_copy