aboutsummaryrefslogtreecommitdiff
path: root/sysutils/usbhotkey
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /sysutils/usbhotkey
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'sysutils/usbhotkey')
-rw-r--r--sysutils/usbhotkey/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/sysutils/usbhotkey/Makefile b/sysutils/usbhotkey/Makefile
index 11388bbd364c..b13605a54c40 100644
--- a/sysutils/usbhotkey/Makefile
+++ b/sysutils/usbhotkey/Makefile
@@ -26,13 +26,15 @@ HAS_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_PTHREADS)
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include \
- -I${LOCALBASE}/include/ruby-${RUBY_VER} -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/ruby-${RUBY_VER} \
+ -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
.else
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include \
- -I${LOCALBASE}/include/ruby-${RUBY_VER} -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/ruby-${RUBY_VER} \
+ -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
+LDFLAGS+= -L${LOCALBASE}/lib
.endif
.if !defined(WITHOUT_GUI)