aboutsummaryrefslogtreecommitdiff
path: root/sysutils/usbhotkey
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-08-03 11:55:57 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-08-03 11:55:57 +0000
commit90ae1f1f9a9d52969481b17a1538348adfb8c5ca (patch)
tree1df6ec927d26849eed0a3090853fe246d594395f /sysutils/usbhotkey
parentddc18dcf1a682bfe3184a02d3132eb0f0a011403 (diff)
downloadports-90ae1f1f9a9d52969481b17a1538348adfb8c5ca.tar.gz
ports-90ae1f1f9a9d52969481b17a1538348adfb8c5ca.zip
- Fix build with clang (needs to link with libX11)
- Port is stage safe and uses GNU Configure MFH: 2014Q3
Notes
Notes: svn path=/head/; revision=363882
Diffstat (limited to 'sysutils/usbhotkey')
-rw-r--r--sysutils/usbhotkey/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/sysutils/usbhotkey/Makefile b/sysutils/usbhotkey/Makefile
index febe90325603..7174579853a1 100644
--- a/sysutils/usbhotkey/Makefile
+++ b/sysutils/usbhotkey/Makefile
@@ -16,12 +16,13 @@ LIB_DEPENDS= libhid.so:${PORTSDIR}/devel/libhid \
USES= gmake
USE_RUBY= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/ruby-${RUBY_VER} \
-I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -lX11
OPTIONS_DEFINE= GUI
OPTIONS_DEFAULT= GUI
@@ -30,5 +31,4 @@ GUI_DESC= Enable GUI bits (via Imlib)
GUI_LIB_DEPENDS= libImlib.so:${PORTSDIR}/graphics/imlib
GUI_CONFIGURE_OFF= --without-Imlib
-NO_STAGE= yes
.include <bsd.port.mk>