aboutsummaryrefslogtreecommitdiff
path: root/sysutils/userneu
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-30 12:10:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-30 12:10:05 +0000
commitd80dfbecc6e71f67f0900d08fd00f6a632355e5a (patch)
tree6e9f63523ca5c6e45b6e9ca4ffb7670a7047b758 /sysutils/userneu
parent6cb400092db07a57f2ee33a6384a5025f8fcef32 (diff)
downloadports-d80dfbecc6e71f67f0900d08fd00f6a632355e5a.tar.gz
ports-d80dfbecc6e71f67f0900d08fd00f6a632355e5a.zip
[NEW PORT] sysutils/userneu: Account management and creation tool
'userneu' is a Perl script that parses a list of usernames and additional information (such as the real name or other information to be put in the GECOS field in /etc/passwd) and creates Unix accounts and (if desired) Samba accounts as well. If the script stumbles upon duplicate user names it can append random characters to the username until it fits. WWW: http://btmdx8.mat.uni-bayreuth.de/~johannes/code.html PR: ports/56753 Submitted by: Andreas Fehlner <fehlner@gmx.de>
Notes
Notes: svn path=/head/; revision=89889
Diffstat (limited to 'sysutils/userneu')
-rw-r--r--sysutils/userneu/Makefile45
-rw-r--r--sysutils/userneu/distinfo1
-rw-r--r--sysutils/userneu/pkg-descr10
-rw-r--r--sysutils/userneu/pkg-plist16
4 files changed, 72 insertions, 0 deletions
diff --git a/sysutils/userneu/Makefile b/sysutils/userneu/Makefile
new file mode 100644
index 000000000000..30bbdd40e909
--- /dev/null
+++ b/sysutils/userneu/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: userneu
+# Date created: 7 August 2003
+# Whom: Andreas Fehlner (fehlner@gmx.de)
+#
+# $FreeBSD$
+#
+
+PORTNAME= userneu
+PORTVERSION= 1.36
+CATEGORIES= sysutils
+MASTER_SITES= http://btmdx8.mat.uni-bayreuth.de/~johannes/files/userneu/ \
+ http://home.arcor.de/fehlner/inhalt/download/
+
+MAINTAINER= fehlner@gmx.de
+COMMENT= Account management and creation tool
+
+RUN_DEPENDS= \
+${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5/ \
+${SITE_PERL}/Crypt/RandPasswd.pm:${PORTSDIR}/security/p5-Crypt-RandPasswd/ \
+${SITE_PERL}/mach/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5/
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GLOCATE= ${PREFIX}/${PORTNAME}
+USE_PERL5= yes
+NO_BUILD= yes
+
+USE_IMAGE= yes
+MANCOMPRESSED= no
+MAN8= userneu.8 userquick.8
+
+DOCS= BUGS CHANGES COPYING CREDITS REQUIREMENTS TODO doc/README doc/INSTALL doc/userneu.pod doc/userquick.pod
+EXAMPLES= list-sample
+
+do-install:
+ ${MKDIR} ${GLOCATE}
+ ${INSTALL_MAN} ${WRKSRC}/doc/userneu.8 ${PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/doc/userquick.8 ${PREFIX}/man/man8
+ ${INSTALL_SCRIPT} ${WRKSRC}/userneu.pl ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/userquick.pl ${PREFIX}/sbin
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/userneu/distinfo b/sysutils/userneu/distinfo
new file mode 100644
index 000000000000..83890adbade7
--- /dev/null
+++ b/sysutils/userneu/distinfo
@@ -0,0 +1 @@
+MD5 (userneu-1.36.tar.gz) = 67ddcaf8539c62c9645ef6b405c04be2
diff --git a/sysutils/userneu/pkg-descr b/sysutils/userneu/pkg-descr
new file mode 100644
index 000000000000..eede843d9639
--- /dev/null
+++ b/sysutils/userneu/pkg-descr
@@ -0,0 +1,10 @@
+'userneu' is a Perl script that parses a list of usernames and additional
+information (such as the real name or other information to be put in the
+GECOS field in /etc/passwd) and creates Unix accounts and (if desired)
+Samba accounts as well. If the script stumbles upon duplicate user names
+it can append random characters to the username until it fits.
+
+WWW: http://btmdx8.mat.uni-bayreuth.de/~johannes/code.html
+
+-Andreas Fehlner
+fehlner@gmx.de
diff --git a/sysutils/userneu/pkg-plist b/sysutils/userneu/pkg-plist
new file mode 100644
index 000000000000..4037215ec06d
--- /dev/null
+++ b/sysutils/userneu/pkg-plist
@@ -0,0 +1,16 @@
+sbin/userneu.pl
+sbin/userquick.pl
+%%DOCSDIR%%/BUGS
+%%DOCSDIR%%/CHANGES
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/REQUIREMENTS
+%%DOCSDIR%%/TODO
+%%DOCSDIR%%/README
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/CREDITS
+%%DOCSDIR%%/userneu.pod
+%%DOCSDIR%%/userquick.pod
+%%EXAMPLESDIR%%/list-sample
+@dirrm %%DOCSDIR%%
+@dirrm %%EXAMPLESDIR%%
+@dirrm userneu