aboutsummaryrefslogtreecommitdiff
path: root/sysutils/vils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-23 19:17:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-23 19:17:33 +0000
commit214a428bd00cf4c39a0a4443a4fa236325c74ba5 (patch)
treed84fbb167cf6ddb28e8d5d9504025c8c45308fd9 /sysutils/vils
parent599372373fe65bfb05753de103d2568cc3d47772 (diff)
downloadports-214a428bd00cf4c39a0a4443a4fa236325c74ba5.tar.gz
ports-214a428bd00cf4c39a0a4443a4fa236325c74ba5.zip
This little script enables you to ``edit an ls'', i.e. it will load a list of
filenames into your favourite editor (presumably vi). Any changes to the filenames will result in renaming the respective files. Read the comments in the script for details. PR: ports/92167 Submitted by: Jeffrey H. Johnson <CPE1704TKS@bellsouth.net>
Notes
Notes: svn path=/head/; revision=154262
Diffstat (limited to 'sysutils/vils')
-rw-r--r--sysutils/vils/Makefile32
-rw-r--r--sysutils/vils/distinfo3
-rw-r--r--sysutils/vils/pkg-descr8
3 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/vils/Makefile b/sysutils/vils/Makefile
new file mode 100644
index 000000000000..40d193d35cab
--- /dev/null
+++ b/sysutils/vils/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: vils
+# Date created: 22 January 2006
+# Whom: Jeffrey H. Johnson <CPE1704TKS@bellsouth.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vils
+PORTVERSION= 20020228
+CATEGORIES= sysutils
+MASTER_SITES= http://www.secnetix.de/~olli/scripts/
+DISTFILES= vils
+
+MAINTAINER= CPE1704TKS@bellsouth.net
+COMMENT= Use your favorite editor to rename files
+
+BUILD_DEPENDS= zsh:${PORTSDIR}/shells/zsh
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PLIST_FILES= bin/vils
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${CP} ${DISTDIR}/vils ${WRKDIR}/vils
+
+do-build:
+ @${REINPLACE_CMD} -e 's/\/bin\/zsh/\/usr\/local\/bin\/zsh/' ${WRKDIR}/vils
+
+do-install:
+ ${INSTALL_SCRIPT} -m 755 ${WRKDIR}/vils ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/vils/distinfo b/sysutils/vils/distinfo
new file mode 100644
index 000000000000..f78b0b7af6f2
--- /dev/null
+++ b/sysutils/vils/distinfo
@@ -0,0 +1,3 @@
+MD5 (vils) = cad9cd336a31154765bba8a55aecebf1
+SHA256 (vils) = b8f7e73a29e3a53b38d22d0be0cc3752a98da853bd4d9bb85538b62491b87dbe
+SIZE (vils) = 2076
diff --git a/sysutils/vils/pkg-descr b/sysutils/vils/pkg-descr
new file mode 100644
index 000000000000..92ad6027cba0
--- /dev/null
+++ b/sysutils/vils/pkg-descr
@@ -0,0 +1,8 @@
+This little script enables you to ``edit an ls'', i.e. it will load a list of
+filenames into your favourite editor (presumably vi). Any changes to the
+filenames will result in renaming the respective files. Read the comments in
+the script for details.
+
+AUTHOR: Oliver Fromme <olli@fromme.com>
+
+BSD-style copyright and standard disclaimer applies.