aboutsummaryrefslogtreecommitdiff
path: root/sysutils/vmdktool
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-08-29 15:05:57 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-08-29 15:05:57 +0000
commitbf033fec3d1ad3354202d4beac3a9d5487567f8f (patch)
treee5c0989015bc7f58f5409c003be66a9ac2de0146 /sysutils/vmdktool
parentb03b3e63e0eed0033960e7ac6240901638b4e078 (diff)
downloadports-bf033fec3d1ad3354202d4beac3a9d5487567f8f.tar.gz
ports-bf033fec3d1ad3354202d4beac3a9d5487567f8f.zip
sysutils/vmdktool: Set TEST_TARGET and WWW, and fix ALL_TARGET
- Set TEST_TARGET. We need a utility called prove that comes with Perl 5 so set USES=perl5 as well. - Set ALL_TARGET to vmdktool. The default one, all, attempts to build vmdktool.8.gz using Groff. Since the final vmdktool.8.gz is never not installed anyway (the install target always installs the original vmdktool.8), it is better to just change the ALL_TARGET to vmdktool directly. This way we do not add dependencies to the build phase. - Set WWW to give users at least some information, even though the project does not have its official homepage. Reviewed by: garga Approved by: maintainer (garga) Differential Revision: https://reviews.freebsd.org/D21464
Notes
Notes: svn path=/head/; revision=510168
Diffstat (limited to 'sysutils/vmdktool')
-rw-r--r--sysutils/vmdktool/Makefile7
-rw-r--r--sysutils/vmdktool/pkg-descr2
2 files changed, 9 insertions, 0 deletions
diff --git a/sysutils/vmdktool/Makefile b/sysutils/vmdktool/Makefile
index 45b11d628d24..4de67bebcbb3 100644
--- a/sysutils/vmdktool/Makefile
+++ b/sysutils/vmdktool/Makefile
@@ -13,7 +13,14 @@ COMMENT= Convert VMDK files to/from raw disk images
LICENSE= BSD2CLAUSE
+USES= perl5
+# We need the prove utility from Perl 5.
+USE_PERL5= test
+
PLIST_FILES= bin/vmdktool \
man/man8/vmdktool.8.gz
+ALL_TARGET= vmdktool
+TEST_TARGET= test
+
.include <bsd.port.mk>
diff --git a/sysutils/vmdktool/pkg-descr b/sysutils/vmdktool/pkg-descr
index a94f43e3a36f..021ad4423969 100644
--- a/sysutils/vmdktool/pkg-descr
+++ b/sysutils/vmdktool/pkg-descr
@@ -8,3 +8,5 @@ VMDK files as the initial filesystem images for the created guests.
vmdktool is free.
Contact the author with any questions or comments.
+
+WWW: http://www.awfulhak.org/vmdktool