aboutsummaryrefslogtreecommitdiff
path: root/sysutils/volman
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-01-07 04:59:41 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-01-07 04:59:41 +0000
commit13d94c2936177ea3c239d80ad62a2f0edf18d496 (patch)
treeaa89d8b1880cf8c5f5b8d73f46caf98810b695f0 /sysutils/volman
parentb706405e3a6b34bb044ea52afedd86ccfcc7a06f (diff)
downloadports-13d94c2936177ea3c239d80ad62a2f0edf18d496.tar.gz
ports-13d94c2936177ea3c239d80ad62a2f0edf18d496.zip
volman is a FreeBSD specific volume manager. It acts
as a translator of devd(8) events, probing storage devices for their file system information, and serving this over a FIFO based API to which clients can subscribe. In addition to notifying clients of new or lost volumes, it will mount and unmount such volumes at the command of subscribing clients. It runs as root and allows any local clients the ability to mount and unmount volumes which are detected, regardless of any user privileges. This is intended for single user X11 systems needing an easy way of accessing USB flash disks on the fly. WWW: http://forums.freebsd.org/showthread.php?t=27233 PR: ports/161977 Submitted by: Aragon Gouveia <aragon@phat.za.net>
Notes
Notes: svn path=/head/; revision=288658
Diffstat (limited to 'sysutils/volman')
-rw-r--r--sysutils/volman/Makefile53
-rw-r--r--sysutils/volman/distinfo2
-rw-r--r--sysutils/volman/files/volmand.in17
-rw-r--r--sysutils/volman/pkg-descr15
-rw-r--r--sysutils/volman/pkg-plist4
5 files changed, 91 insertions, 0 deletions
diff --git a/sysutils/volman/Makefile b/sysutils/volman/Makefile
new file mode 100644
index 000000000000..41e38f415a82
--- /dev/null
+++ b/sysutils/volman/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: volman
+# Date created: 2012-01-06
+# Whom: Aragon Gouveia <aragon@phat.za.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= volman
+PORTVERSION= 0.7
+CATEGORIES= sysutils
+MASTER_SITES= http://cloud.github.com/downloads/jmptbl/volman/
+
+MAINTAINER= aragon@phat.za.net
+COMMENT= FreeBSD specific volume manager
+
+USE_XZ= yes
+USE_RC_SUBR= volmand
+VM_SUB_FILES= vmount volmand
+
+OPTIONS= OPENBOX "Install Openbox pipemenu script" off \
+ NTFS3G "Use fusefs-ntfs extensions" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_OPENBOX)
+VM_SUB_FILES+= obvolman
+RUN_DEPENDS+= ${LOCALBASE}/bin/xmessage:${PORTSDIR}/x11/xmessage
+PLIST_SUB+= OPENBOX=""
+.else
+PLIST_SUB+= OPENBOX="@comment "
+.endif
+
+.if defined(WITH_NTFS3G)
+RUN_DEPENDS+= ${LOCALBASE}/bin/ntfs-3g:${PORTSDIR}/sysutils/fusefs-ntfs
+SUB_LIST+= RCFUSEFS=" fusefs"
+.else
+SUB_LIST+= RCFUSEFS=""
+.endif
+
+do-build:
+.for file in ${VM_SUB_FILES}
+ ${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${WRKSRC}/${file}.in >${WRKSRC}/${file}
+.endfor
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/volmand ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/vmount ${PREFIX}/bin
+.if defined(WITH_OPENBOX)
+ ${INSTALL_SCRIPT} ${WRKSRC}/obvolman ${PREFIX}/bin
+.endif
+ ${INSTALL_DATA} ${WRKSRC}/volman.conf ${PREFIX}/etc/volman.conf.sample
+
+.include <bsd.port.mk>
diff --git a/sysutils/volman/distinfo b/sysutils/volman/distinfo
new file mode 100644
index 000000000000..508629243a92
--- /dev/null
+++ b/sysutils/volman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (volman-0.7.tar.xz) = a2efc86f990b547245f58ec3db20059f597ad040805b6834fc6b9aab66df78b5
+SIZE (volman-0.7.tar.xz) = 4988
diff --git a/sysutils/volman/files/volmand.in b/sysutils/volman/files/volmand.in
new file mode 100644
index 000000000000..4c5eaf05e8ca
--- /dev/null
+++ b/sysutils/volman/files/volmand.in
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: volmand
+# REQUIRE: LOGIN
+# KEYWORD: shutdown nojail
+
+. /etc/rc.subr
+
+name="volmand"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/sbin/volmand"
+load_rc_config $name
+pidfile="/var/run/volmand.pid"
+
+run_rc_command "$1"
diff --git a/sysutils/volman/pkg-descr b/sysutils/volman/pkg-descr
new file mode 100644
index 000000000000..b1f5ea52d046
--- /dev/null
+++ b/sysutils/volman/pkg-descr
@@ -0,0 +1,15 @@
+volman is a FreeBSD specific volume manager. It acts
+as a translator of devd(8) events, probing storage
+devices for their file system information, and serving
+this over a FIFO based API to which clients can
+subscribe. In addition to notifying clients of new
+or lost volumes, it will mount and unmount such
+volumes at the command of subscribing clients.
+
+It runs as root and allows any local clients the
+ability to mount and unmount volumes which are
+detected, regardless of any user privileges. This
+is intended for single user X11 systems needing
+an easy way of accessing USB flash disks on the fly.
+
+WWW: http://forums.freebsd.org/showthread.php?t=27233
diff --git a/sysutils/volman/pkg-plist b/sysutils/volman/pkg-plist
new file mode 100644
index 000000000000..b41f7e55d9bf
--- /dev/null
+++ b/sysutils/volman/pkg-plist
@@ -0,0 +1,4 @@
+etc/volman.conf.sample
+sbin/volmand
+bin/vmount
+%%OPENBOX%%bin/obvolman