aboutsummaryrefslogtreecommitdiff
path: root/sysutils/webjob
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-04-02 12:39:26 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-04-02 12:39:26 +0000
commit3dcce89b74b95a8023462ccc4a717f5fd683ba4e (patch)
tree59c9be407c956267221fe91a39e90defe89c2198 /sysutils/webjob
parent21f8fdab6e5caf8f77664cb78e0d2b9a058871cc (diff)
downloadports-3dcce89b74b95a8023462ccc4a717f5fd683ba4e.tar.gz
ports-3dcce89b74b95a8023462ccc4a717f5fd683ba4e.zip
Add webjob 1.2.3, download and execute a program over HTTP/HTTPS.
PR: 42372 Submitted by: Klayton Monroe <klm@ir.exodus.net>
Notes
Notes: svn path=/head/; revision=77985
Diffstat (limited to 'sysutils/webjob')
-rw-r--r--sysutils/webjob/Makefile34
-rw-r--r--sysutils/webjob/distinfo1
-rw-r--r--sysutils/webjob/pkg-descr9
-rw-r--r--sysutils/webjob/pkg-message12
-rw-r--r--sysutils/webjob/pkg-plist15
5 files changed, 71 insertions, 0 deletions
diff --git a/sysutils/webjob/Makefile b/sysutils/webjob/Makefile
new file mode 100644
index 000000000000..d756d6230265
--- /dev/null
+++ b/sysutils/webjob/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: webjob
+# Date created: 20 August 2002
+# Whom: Klayton Monroe <klm@ir.exodus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webjob
+PORTVERSION= 1.2.3
+CATEGORIES= sysutils security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= webjob
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= klm@ir.exodus.net
+COMMENT= Download and execute a program over HTTP/HTTPS
+
+MAN1= webjob.1
+
+GNU_CONFIGURE= YES
+
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS= --without-ssl
+.else
+USE_OPENSSL= YES
+CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
+.endif
+
+pre-build:
+ @${MV} ${WRKSRC}/etc/webjob.cfg ${WRKSRC}/etc/webjob.cfg.sample
+ @${MV} ${WRKSRC}/etc/Makefile ${WRKSRC}/etc/Makefile.orig
+ @${SED} 's/webjob.cfg/webjob.cfg.sample/g' ${WRKSRC}/etc/Makefile.orig > ${WRKSRC}/etc/Makefile
+
+.include <bsd.port.mk>
diff --git a/sysutils/webjob/distinfo b/sysutils/webjob/distinfo
new file mode 100644
index 000000000000..6a7898420089
--- /dev/null
+++ b/sysutils/webjob/distinfo
@@ -0,0 +1 @@
+MD5 (webjob-1.2.3.tgz) = a9cbbd931d8280b08698e99c40aa1a5a
diff --git a/sysutils/webjob/pkg-descr b/sysutils/webjob/pkg-descr
new file mode 100644
index 000000000000..47375b8a25a6
--- /dev/null
+++ b/sysutils/webjob/pkg-descr
@@ -0,0 +1,9 @@
+WebJob downloads a program over HTTP/HTTPS and executes it in one
+unified operation. The output, if any, may be directed to stdout/stderr
+or a Web resource. WebJob may be useful in incident response and
+intrusion analysis as it provides a mechanism to run known good
+diagnostic programs on a potentially compromised system. It can
+also support a variety of centralized management and host-based
+monitoring solutions.
+
+WWW: http://webjob.sourceforge.net/WebJob/
diff --git a/sysutils/webjob/pkg-message b/sysutils/webjob/pkg-message
new file mode 100644
index 000000000000..a59f3a71ae04
--- /dev/null
+++ b/sysutils/webjob/pkg-message
@@ -0,0 +1,12 @@
+
+----------------------------------------------------------------------
+ If necessary, check the value of ${PREFIX} and update your PATH
+ and MANPATH environment variables accordingly. By default, WebJob
+ is rooted in the following location: /usr/local/integrity.
+
+ For information on how to configure an Apache Web server to handle
+ WebJob requests and verify client-server connectivity, refer to
+ the INSTALL document located in the project's source tree.
+
+ A sample configuration file can be found in ${PREFIX}/etc.
+----------------------------------------------------------------------
diff --git a/sysutils/webjob/pkg-plist b/sysutils/webjob/pkg-plist
new file mode 100644
index 000000000000..776e2e57fbab
--- /dev/null
+++ b/sysutils/webjob/pkg-plist
@@ -0,0 +1,15 @@
+bin/pad-join
+bin/pad-make-binary
+bin/pad-make-script
+bin/webjob
+cgi/cgi-client/nph-webjob.cgi
+doc/webjob.html
+etc/webjob.cfg.sample
+@unexec rmdir %D/bin 2> /dev/null || true
+@unexec rmdir %D/cgi/cgi-client 2> /dev/null || true
+@unexec rmdir %D/cgi 2> /dev/null || true
+@unexec rmdir %D/doc 2> /dev/null || true
+@unexec rmdir %D/etc 2> /dev/null || true
+@unexec rmdir %D/man/man1 2> /dev/null || true
+@unexec rmdir %D/man 2> /dev/null || true
+@unexec rmdir %D 2> /dev/null || true