aboutsummaryrefslogtreecommitdiff
path: root/sysutils/wmupmon
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-11-28 14:05:57 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-11-28 14:05:57 +0000
commit4ab47043d5f9bacf36dc258b8bdfaaba89749230 (patch)
treedb71d073f9a44c9f5b1a775dba2a19e8490302cc /sysutils/wmupmon
parent94d4a13794f527db92cc9745d351a4a09eb6870e (diff)
downloadports-4ab47043d5f9bacf36dc258b8bdfaaba89749230.tar.gz
ports-4ab47043d5f9bacf36dc258b8bdfaaba89749230.zip
Fix segfaults on amd64
Pass maintainership to submitter PR: ports/152580 Submitted by: Rainer Hurling <rhurlin at gwdg.de>
Notes
Notes: svn path=/head/; revision=265318
Diffstat (limited to 'sysutils/wmupmon')
-rw-r--r--sysutils/wmupmon/Makefile6
-rw-r--r--sysutils/wmupmon/distinfo1
-rw-r--r--sysutils/wmupmon/files/patch-src_main.c40
3 files changed, 43 insertions, 4 deletions
diff --git a/sysutils/wmupmon/Makefile b/sysutils/wmupmon/Makefile
index 9d1641f9a01d..574e307cc964 100644
--- a/sysutils/wmupmon/Makefile
+++ b/sysutils/wmupmon/Makefile
@@ -7,11 +7,11 @@
PORTNAME= wmupmon
PORTVERSION= 0.1.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= sysutils windowmaker
-MASTER_SITES= http://j-z-s.com/projects/downloads/
+MASTER_SITES= http://www.dockapps.org/files/188/547/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rhurlin@gwdg.de
COMMENT= An uptime showing dockapp with a similar look to wmcpuload
USE_BZIP2= yes
diff --git a/sysutils/wmupmon/distinfo b/sysutils/wmupmon/distinfo
index f67e74917876..3297c9482e14 100644
--- a/sysutils/wmupmon/distinfo
+++ b/sysutils/wmupmon/distinfo
@@ -1,3 +1,2 @@
-MD5 (wmupmon-0.1.3.tar.bz2) = 5de5cf7c074f15bb5d8d7d6beb5f4268
SHA256 (wmupmon-0.1.3.tar.bz2) = 7583f163fa472ec72a4f952c2ece8648a3ca709e4594b2b1591987671b0f38bc
SIZE (wmupmon-0.1.3.tar.bz2) = 90108
diff --git a/sysutils/wmupmon/files/patch-src_main.c b/sysutils/wmupmon/files/patch-src_main.c
new file mode 100644
index 000000000000..b83afc8c65b7
--- /dev/null
+++ b/sysutils/wmupmon/files/patch-src_main.c
@@ -0,0 +1,40 @@
+--- src/main.c 2004-12-11 19:07:21.000000000 +0000
++++ src/main.c 2007-01-31 12:20:47.000000000 +0000
+@@ -66,10 +66,8 @@
+ int main(int argc, char **argv)
+ {
+ int i, a, aa, b, bb;
+- char* real_off_xpm[(style == 2 ? sizeof(backlight2_off_xpm) :
+- sizeof(backlight_off_xpm))];
+- char* real_on_xpm[(style == 2 ? sizeof(backlight2_on_xpm) :
+- sizeof(backlight_on_xpm))];
++ char** real_off_xpm;
++ char** real_on_xpm;
+ XEvent event;
+ XpmColorSymbol colors[2] = { {"Back0", NULL, 0}, {"Back1", NULL, 0} };
+ int ncolor = 0;
+@@ -79,20 +77,12 @@
+
+ /* setup pixmap to use - this is ugly but it works */
+
+- a = sizeof(backlight2_off_xpm);
+- aa = sizeof(backlight2_on_xpm);
+- b = sizeof(backlight_off_xpm);
+- bb = sizeof(backlight_on_xpm);
+ if(style == 2){
+- for(i=0; i<a; i++)
+- real_off_xpm[i] = backlight2_off_xpm[i];
+- for(i=0; i<aa; i++)
+- real_on_xpm[i] = backlight2_on_xpm[i];
++ real_off_xpm = backlight2_off_xpm;
++ real_on_xpm = backlight2_on_xpm;
+ } else {
+- for(i=0; i<b; i++)
+- real_off_xpm[i] = backlight_off_xpm[i];
+- for(i=0; i<bb; i++)
+- real_on_xpm[i] = backlight_on_xpm[i];
++ real_off_xpm = backlight_off_xpm;
++ real_on_xpm = backlight_on_xpm;
+ }
+
+ /* Initialize Application */