aboutsummaryrefslogtreecommitdiff
path: root/sysutils/x86info
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2018-01-11 17:57:44 +0000
committerSean Bruno <sbruno@FreeBSD.org>2018-01-11 17:57:44 +0000
commit70e5afba3d6e5c3b47408f4a92c9f510719e0ccf (patch)
treead744c37228763a72621d8e471d2350da1a1caf9 /sysutils/x86info
parent4eb24c2e8e9a765c507b369cdc337826d330f1b2 (diff)
downloadports-70e5afba3d6e5c3b47408f4a92c9f510719e0ccf.tar.gz
ports-70e5afba3d6e5c3b47408f4a92c9f510719e0ccf.zip
Notes
Diffstat (limited to 'sysutils/x86info')
-rw-r--r--sysutils/x86info/Makefile4
-rw-r--r--sysutils/x86info/distinfo6
-rw-r--r--sysutils/x86info/files/patch-Makefile20
-rw-r--r--sysutils/x86info/files/patch-cpuid.c18
-rw-r--r--sysutils/x86info/files/patch-cpuid_freebsd.c25
5 files changed, 54 insertions, 19 deletions
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index 66b8dd91c839..4c2471ba04ef 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= x86info
-DISTVERSION= 1.31snap01
+DISTVERSION= 1.31snap02
CATEGORIES= sysutils
MAINTAINER= ports@FreeBSD.org
@@ -17,7 +17,7 @@ ONLY_FOR_ARCHS= i386 amd64
USE_GITHUB= yes
GH_ACCOUNT= kernelslacker
-GH_TAGNAME= 636fbaa
+GH_TAGNAME= b7d0839
USES= gmake pkgconfig python:build
diff --git a/sysutils/x86info/distinfo b/sysutils/x86info/distinfo
index 13c2526139a7..0d7fa5369788 100644
--- a/sysutils/x86info/distinfo
+++ b/sysutils/x86info/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480247467
-SHA256 (kernelslacker-x86info-1.31snap01-636fbaa_GH0.tar.gz) = 86f832da6ffcb2097fb10d6bab279d15470357f2efbbf1afd647fa26cd056e8c
-SIZE (kernelslacker-x86info-1.31snap01-636fbaa_GH0.tar.gz) = 85199
+TIMESTAMP = 1515691206
+SHA256 (kernelslacker-x86info-1.31snap02-b7d0839_GH0.tar.gz) = eda506bac6352ac3f0a2de26601fe98a399f055d52c65298a47e12ce5ef64677
+SIZE (kernelslacker-x86info-1.31snap02-b7d0839_GH0.tar.gz) = 85805
diff --git a/sysutils/x86info/files/patch-Makefile b/sysutils/x86info/files/patch-Makefile
index 7a0a29ef08a5..4f80b57aad83 100644
--- a/sysutils/x86info/files/patch-Makefile
+++ b/sysutils/x86info/files/patch-Makefile
@@ -1,15 +1,7 @@
---- Makefile.orig 2016-10-12 19:04:55 UTC
-+++ Makefile
-@@ -18,6 +18,7 @@ CFLAGS += -Wstrict-prototypes -Wmissing-
- CFLAGS += -Wswitch-enum
- CFLAGS += -Wundef
- CFLAGS += -Wwrite-strings
-+CFLAGS += `pkg-config --cflags libpci`
-
- # gcc specific
- ifneq ($(shell $(CC) -v 2>&1 | grep -c "clang"), 1)
-@@ -37,7 +38,7 @@ CFLAGS += $(shell if [ $(CPP_MAJOR) -eq
- LDFLAGS = -Wl,-z,relro,-z,now
+--- Makefile.orig 2017-09-06 10:17:13.000000000 -0600
++++ Makefile 2018-01-11 10:23:07.741490000 -0700
+@@ -39,7 +39,7 @@
+ LDFLAGS += $(shell pkg-config --libs libpci)
ifeq ($(CC),"")
-CC = gcc
@@ -17,7 +9,7 @@
endif
ifdef STATIC_LIBPCI
-@@ -50,7 +51,7 @@ SHELL = /bin/sh
+@@ -52,7 +52,7 @@
V = @
Q = $(V:1=)
@@ -26,7 +18,7 @@
all: x86info
-@@ -67,7 +68,7 @@ X86INFO_OBJS = $(sort $(patsubst %.c,%.o
+@@ -69,7 +69,7 @@
x86info: $(X86INFO_OBJS) $(X86INFO_HEADERS)
$(QUIET_CC)$(CC) $(CFLAGS) $(LDFLAGS) -o x86info $(X86INFO_OBJS) \
diff --git a/sysutils/x86info/files/patch-cpuid.c b/sysutils/x86info/files/patch-cpuid.c
new file mode 100644
index 000000000000..e8af0616ce94
--- /dev/null
+++ b/sysutils/x86info/files/patch-cpuid.c
@@ -0,0 +1,18 @@
+--- cpuid.c.orig 2017-09-06 10:17:13.000000000 -0600
++++ cpuid.c 2018-01-11 10:34:12.018249000 -0700
+@@ -21,14 +21,7 @@
+ {
+ unsigned int a = 0, b = 0, c = 0, d = 0;
+
+- if (eax != NULL)
+- a = *eax;
+- if (ebx != NULL)
+- b = *ebx;
+- if (ecx != NULL)
+- c = *ecx;
+- if (edx != NULL)
+- d = *edx;
++ c = idx >> 32;
+
+ bind_cpu(cpunr);
+
diff --git a/sysutils/x86info/files/patch-cpuid_freebsd.c b/sysutils/x86info/files/patch-cpuid_freebsd.c
new file mode 100644
index 000000000000..dc2953b0d7b7
--- /dev/null
+++ b/sysutils/x86info/files/patch-cpuid_freebsd.c
@@ -0,0 +1,25 @@
+--- cpuid-freebsd.c.orig 2017-09-06 10:17:13.000000000 -0600
++++ cpuid-freebsd.c 2018-01-11 10:34:01.353720000 -0700
+@@ -39,7 +39,7 @@
+ static int nodriver=0;
+ char cpuname[20];
+ int fh;
+- cpuctl_cpuid_args_t args;
++ cpuctl_cpuid_count_args_t args;
+
+ if (nodriver == 1) {
+ if (native_cpuid(CPU_number, idx, eax,ebx,ecx,edx))
+@@ -48,11 +48,12 @@
+ }
+
+ args.level = idx;
++ args.level_type = idx >> 32;
+ /* Ok, use the /dev/CPU interface in preference to the _up code. */
+ (void)snprintf(cpuname, sizeof(cpuname), "/dev/cpuctl%u", CPU_number);
+ fh = open(cpuname, O_RDONLY);
+ if (fh != -1) {
+- if (ioctl(fh, CPUCTL_CPUID, &args) != 0) {
++ if (ioctl(fh, CPUCTL_CPUID_COUNT, &args) != 0) {
+ perror(cpuname);
+ exit(EXIT_FAILURE);
+ }