aboutsummaryrefslogtreecommitdiff
path: root/sysutils/x86info
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-08-15 14:38:06 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-08-15 14:38:06 +0000
commit9f1cc627fb0bf5a89afcac77f0dca0285adc856a (patch)
tree89694acabbc752336021cd7f1fcf856688d75cf8 /sysutils/x86info
parentafa52eec8438723e087823a97e950278869332dd (diff)
downloadports-9f1cc627fb0bf5a89afcac77f0dca0285adc856a.tar.gz
ports-9f1cc627fb0bf5a89afcac77f0dca0285adc856a.zip
- Update to 1.18 [1]
- Fix pkg-descr (we don't support MSR reading on FreeBSD) [1] - Respect DESTDIR while here PR: ports/101722 [1] Submitted by: Stanislav Sedov <ssedov@mbsd.msk.ru> [1] Approved by: Erik Greenwald <erik@smluc.org> (maintainer)
Notes
Notes: svn path=/head/; revision=170710
Diffstat (limited to 'sysutils/x86info')
-rw-r--r--sysutils/x86info/Makefile4
-rw-r--r--sysutils/x86info/distinfo6
-rw-r--r--sysutils/x86info/files/patch-cpuid.c20
-rw-r--r--sysutils/x86info/files/patch-x86info.h11
-rw-r--r--sysutils/x86info/pkg-descr4
5 files changed, 17 insertions, 28 deletions
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index 09a0e9f38846..233eb1b11a3e 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= x86info
-PORTVERSION= 1.17
+PORTVERSION= 1.18
CATEGORIES= sysutils
MASTER_SITES= http://www.codemonkey.org.uk/projects/x86info/ \
${MASTER_SITE_SOURCEFORGE}
@@ -21,6 +21,6 @@ PLIST_FILES= bin/x86info
MAKE_ARGS= CFLAGS="${CFLAGS}"
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/x86info ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/x86info ${TARGETDIR}/bin
.include <bsd.port.mk>
diff --git a/sysutils/x86info/distinfo b/sysutils/x86info/distinfo
index 0ca267c67ee2..94cc95e2e5e1 100644
--- a/sysutils/x86info/distinfo
+++ b/sysutils/x86info/distinfo
@@ -1,3 +1,3 @@
-MD5 (x86info-1.17.tgz) = bef27fba7b0c3a9aeda63372a670f3a9
-SHA256 (x86info-1.17.tgz) = c9f7a0183af65b8e7777757a9abe593caed7c4696d4af7421871243785aadeff
-SIZE (x86info-1.17.tgz) = 51625
+MD5 (x86info-1.18.tgz) = 6886cbabc9c8155212b9a3d0b2d37a5f
+SHA256 (x86info-1.18.tgz) = 9ef3bba774504a92518b2d7ba6a431f58d677c5c483cca79275a08e47a70f56f
+SIZE (x86info-1.18.tgz) = 52374
diff --git a/sysutils/x86info/files/patch-cpuid.c b/sysutils/x86info/files/patch-cpuid.c
index c7938b5b540b..667257bce2ea 100644
--- a/sysutils/x86info/files/patch-cpuid.c
+++ b/sysutils/x86info/files/patch-cpuid.c
@@ -1,11 +1,11 @@
---- cpuid.c.orig Sat Nov 26 20:51:01 2005
-+++ cpuid.c Sat Nov 26 20:51:24 2005
-@@ -40,7 +40,7 @@
- snprintf (cpuname,18, "/dev/cpu/%d/cpuid", CPU_number);
- fh = open (cpuname, O_RDONLY);
+--- cpuid.c.orig Wed Aug 9 22:54:05 2006
++++ cpuid.c Wed Aug 9 22:54:20 2006
+@@ -42,7 +42,7 @@
+ fh = open(cpuname, O_RDONLY);
if (fh != -1) {
-- lseek64 (fh, (off64_t)idx, SEEK_CUR);
-+ lseek (fh, (off_t)idx, SEEK_CUR);
- read (fh, &buffer[0], 16);
- if (eax!=0) *eax = (*(unsigned *)(buffer ));
- if (ebx!=0) *ebx = (*(unsigned *)(buffer+ 4));
+ #ifndef S_SPLINT_S
+- lseek64(fh, (off64_t)idx, SEEK_CUR);
++ lseek(fh, (off_t)idx, SEEK_CUR);
+ #endif
+ if (read(fh, &buffer[0], 16) == -1) {
+ perror(cpuname);
diff --git a/sysutils/x86info/files/patch-x86info.h b/sysutils/x86info/files/patch-x86info.h
deleted file mode 100644
index 54957188c8eb..000000000000
--- a/sysutils/x86info/files/patch-x86info.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- x86info.h.orig Tue Oct 4 19:13:58 2005
-+++ x86info.h Tue Oct 4 19:14:04 2005
-@@ -1,7 +1,7 @@
- #ifndef _X86INFO_H
- #define _X86INFO_H
-
--#include <linux/types.h>
-+#include <sys/types.h>
- typedef unsigned char u8;
- typedef unsigned short u16;
- typedef unsigned int u32;
diff --git a/sysutils/x86info/pkg-descr b/sysutils/x86info/pkg-descr
index e17a7f82124c..ec9c9f300e05 100644
--- a/sysutils/x86info/pkg-descr
+++ b/sysutils/x86info/pkg-descr
@@ -1,3 +1,3 @@
The x86info utility displays information about each of the systems 80x86
-processors. Cache info, flags, registers, msr's, and processor
-name/family/model are all displayed.
+processors. Cache info, flags, registers, and processor name/family/model
+are all displayed.