aboutsummaryrefslogtreecommitdiff
path: root/sysutils/x86info
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-09-04 13:53:25 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-09-04 13:53:25 +0000
commitba524edcd66b05bd3f6482b252cad7c562aa394e (patch)
tree565c07b5d11f6d4150f008ce964ee8b630107592 /sysutils/x86info
parent184cce40686a515c020939cb3da79bd887888325 (diff)
downloadports-ba524edcd66b05bd3f6482b252cad7c562aa394e.tar.gz
ports-ba524edcd66b05bd3f6482b252cad7c562aa394e.zip
- Add patch to teach this port to read MSRs for centrino cpu model 13.
- bump PORTREVISION. PR: ports/102452 Submitted by: Stanislav Sedov Approved by: Erik Greenwald (maintainer)
Notes
Notes: svn path=/head/; revision=172180
Diffstat (limited to 'sysutils/x86info')
-rw-r--r--sysutils/x86info/Makefile1
-rw-r--r--sysutils/x86info/files/patch-Intel_info.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index 233eb1b11a3e..d323ae27d47d 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -7,6 +7,7 @@
PORTNAME= x86info
PORTVERSION= 1.18
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.codemonkey.org.uk/projects/x86info/ \
${MASTER_SITE_SOURCEFORGE}
diff --git a/sysutils/x86info/files/patch-Intel_info.c b/sysutils/x86info/files/patch-Intel_info.c
new file mode 100644
index 000000000000..fcb768cd51d1
--- /dev/null
+++ b/sysutils/x86info/files/patch-Intel_info.c
@@ -0,0 +1,11 @@
+--- Intel/info.c.orig Thu Aug 24 01:24:35 2006
++++ Intel/info.c Thu Aug 24 01:25:13 2006
+@@ -35,7 +35,7 @@
+ if (show_msr) {
+ if (cpu->family==0xf)
+ dump_p4_MSRs(cpu);
+- if (cpu->family==0x6 && cpu->model==9)
++ if (cpu->family==0x6 && (cpu->model == 9 || cpu->model == 13))
+ dump_centrino_MSRs(cpu);
+ }
+