aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xen-guest-tools
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2020-04-21 17:52:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2020-04-21 17:52:36 +0000
commitb1077347b7c057f5d11271e1d9587117fbb9ee09 (patch)
treeb6d1bc8b46323b61c68b35a656e94a5ecc39cca5 /sysutils/xen-guest-tools
parentc857bffd8b26fd3a584ebb43856660b8bb1a8ce0 (diff)
downloadports-b1077347b7c057f5d11271e1d9587117fbb9ee09.tar.gz
ports-b1077347b7c057f5d11271e1d9587117fbb9ee09.zip
- fix build for CURRENT
- speedup build PR: 245658
Notes
Notes: svn path=/head/; revision=532288
Diffstat (limited to 'sysutils/xen-guest-tools')
-rw-r--r--sysutils/xen-guest-tools/Makefile5
-rw-r--r--sysutils/xen-guest-tools/files/patch-tools-Makefile18
2 files changed, 14 insertions, 9 deletions
diff --git a/sysutils/xen-guest-tools/Makefile b/sysutils/xen-guest-tools/Makefile
index 5dfbbd6ed6b0..a70031db1d62 100644
--- a/sysutils/xen-guest-tools/Makefile
+++ b/sysutils/xen-guest-tools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xen-guest-tools
PORTVERSION= 4.13.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= https://downloads.xenproject.org/release/xen/${PORTVERSION}/
DISTNAME= xen-${PORTVERSION}
@@ -37,6 +37,7 @@ MAKE_ENV+= clang=y
MAKE_ENV+= CC="${CC}"
MAKE_ENV+= CFLAGS="${CFLAGS}"
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}"
+MAKE_ENV+= FREEBSD_PORT=y
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -I${LOCALBASE}/lib
USE_LDCONFIG= yes
@@ -57,6 +58,8 @@ PLIST_FILES= bin/xen-detect \
lib/libxentoolcore.so.1
post-patch:
+ ${REINPLACE_CMD} -e 's;=xen tools stubdom docs;=tools;' \
+ ${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's;86|x86_64;86no|x86_64no;' \
${WRKSRC}/tools/configure
diff --git a/sysutils/xen-guest-tools/files/patch-tools-Makefile b/sysutils/xen-guest-tools/files/patch-tools-Makefile
index cea8de2d40d1..65025e9c1b8a 100644
--- a/sysutils/xen-guest-tools/files/patch-tools-Makefile
+++ b/sysutils/xen-guest-tools/files/patch-tools-Makefile
@@ -1,10 +1,12 @@
--- tools/Makefile.orig 2019-12-17 14:23:09 UTC
+++ tools/Makefile
-@@ -15,7 +15,6 @@ SUBDIRS-y += examples
- SUBDIRS-y += hotplug
- SUBDIRS-y += xentrace
- SUBDIRS-$(CONFIG_XCUTILS) += xcutils
--SUBDIRS-$(CONFIG_X86) += firmware
- SUBDIRS-y += console
- SUBDIRS-y += xenmon
- SUBDIRS-y += xenstat
+@@ -50,6 +50,9 @@ endif
+ ifeq ($(CONFIG_RUMP),y)
+ SUBDIRS-y := libs libxc xenstore
+ endif
++ifeq ($(FREEBSD_PORT),y)
++SUBDIRS-y := libs libxc xenstore misc
++endif
+
+ # For the sake of linking, set the sys-root
+ ifneq ($(CROSS_COMPILE),)