aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xen-guest-tools
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2016-06-02 08:12:47 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2016-06-02 08:12:47 +0000
commite09f287a7fd4e05663c3b91dc73f340968122626 (patch)
tree43ad4e590853261cf81228ca4036664cb58f8b5f /sysutils/xen-guest-tools
parent0ffcdaf7376eb088d9821b5f5ef50fa9e8a33330 (diff)
downloadports-e09f287a7fd4e05663c3b91dc73f340968122626.tar.gz
ports-e09f287a7fd4e05663c3b91dc73f340968122626.zip
- update to 4.6.1
Submitted by: Jan van Stekelenburg - make portlint happier
Notes
Notes: svn path=/head/; revision=416273
Diffstat (limited to 'sysutils/xen-guest-tools')
-rw-r--r--sysutils/xen-guest-tools/Makefile19
-rw-r--r--sysutils/xen-guest-tools/distinfo4
-rw-r--r--sysutils/xen-guest-tools/files/patch-config_StdGNU.mk5
3 files changed, 14 insertions, 14 deletions
diff --git a/sysutils/xen-guest-tools/Makefile b/sysutils/xen-guest-tools/Makefile
index 82873bdea1ce..a4fc242249da 100644
--- a/sysutils/xen-guest-tools/Makefile
+++ b/sysutils/xen-guest-tools/Makefile
@@ -2,33 +2,32 @@
# $FreeBSD$
PORTNAME= xen-guest-tools
-PORTVERSION= 4.2.2
-PORTREVISION= 1
+PORTVERSION= 4.6.1
CATEGORIES= sysutils
+MASTER_SITES= http://bits.xensource.com/oss-xen/release/${PORTVERSION}/
DISTNAME= xen-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Xen tools within FreeBSD domU
-MASTER_SITES= http://bits.xensource.com/oss-xen/release/${PORTVERSION}/
-DISTFILES= xen-${PORTVERSION}.tar.gz
-
BUILD_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash \
${LOCALBASE}/lib/libglib-2.0.so:devel/glib20 \
+ ${LOCALBASE}/lib/libargp.so:devel/argp-standalone \
${LOCALBASE}/lib/libyajl.so:devel/yajl
+ONLY_FOR_ARCHS= amd64 i386 ia64
+ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than amd64, i386, or ia64"
+CONFLICTS= xen-tools-[0-9]*
+
USES= gmake python:2.7:configure perl5 gettext-runtime:build gettext-tools:build pkgconfig
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ENV+= PYTHON=${PYTHON_CMD} PYTHON_PATH=${PYTHON_CMD}
CONFIGURE_ENV+= APPEND_LIB="${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -I${LOCALBASE}/lib
USE_LDCONFIG= yes
-CONFLICTS= xen-tools-[0-9]*
-
-ONLY_FOR_ARCHS= amd64 i386 ia64
-ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than amd64, i386, or ia64"
-
PLIST_FILES= lib/libxenstore.so.3.0 \
bin/xen-detect \
bin/xenstore \
diff --git a/sysutils/xen-guest-tools/distinfo b/sysutils/xen-guest-tools/distinfo
index 8f257664cd8c..4762ebcadd3a 100644
--- a/sysutils/xen-guest-tools/distinfo
+++ b/sysutils/xen-guest-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xen-4.2.2.tar.gz) = c9bfe91a5e72f8545acebad9889d64368020359bfe18044c0e683133e55ae005
-SIZE (xen-4.2.2.tar.gz) = 15602746
+SHA256 (xen-4.6.1.tar.gz) = 44cc2fccba1e147ef4c8da0584ce0f24189c8743de0e3e9a9226da88ddb5f589
+SIZE (xen-4.6.1.tar.gz) = 19693042
diff --git a/sysutils/xen-guest-tools/files/patch-config_StdGNU.mk b/sysutils/xen-guest-tools/files/patch-config_StdGNU.mk
index 90eeb4cec51c..cc952459a602 100644
--- a/sysutils/xen-guest-tools/files/patch-config_StdGNU.mk
+++ b/sysutils/xen-guest-tools/files/patch-config_StdGNU.mk
@@ -1,15 +1,16 @@
--- config/StdGNU.mk.orig 2013-04-23 18:42:55.000000000 +0200
+++ config/StdGNU.mk 2015-01-30 09:12:53.000000000 +0100
-@@ -1,10 +1,10 @@
+@@ -1,11 +1,11 @@
AS = $(CROSS_COMPILE)as
LD = $(CROSS_COMPILE)ld
ifeq ($(clang),y)
-CC = $(CROSS_COMPILE)clang
+CC ?= $(CROSS_COMPILE)clang
+ CXX = $(CROSS_COMPILE)clang++
LD_LTO = $(CROSS_COMPILE)llvm-ld
else
-CC = $(CROSS_COMPILE)gcc
+CC ?= $(CROSS_COMPILE)gcc
+ CXX = $(CROSS_COMPILE)g++
LD_LTO = $(CROSS_COMPILE)ld
endif
- CPP = $(CC) -E