aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xen-tools
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2020-09-23 15:06:46 +0000
committerDima Panov <fluffy@FreeBSD.org>2020-09-23 15:06:46 +0000
commitaa70834b9312f05556acfdabf094466476b14a59 (patch)
tree8dcfcdf2474a91997004b5f13c40adfeb68c2a02 /sysutils/xen-tools
parent70ea61b0b8533b65a27156fa15b98e6e88e0dad8 (diff)
downloadports-aa70834b9312f05556acfdabf094466476b14a59.tar.gz
ports-aa70834b9312f05556acfdabf094466476b14a59.zip
sysutils/xen-tools: unbreak packaging
Unbreak package with python!=3.7 Switch to use py3.6+ only Use BINARY_ALIAS for python3 Bump PORTREVISION PR: 249541 Submitted by: fluffy Approved by: maintainer (royger)
Notes
Notes: svn path=/head/; revision=549738
Diffstat (limited to 'sysutils/xen-tools')
-rw-r--r--sysutils/xen-tools/Makefile6
-rw-r--r--sysutils/xen-tools/pkg-plist2
2 files changed, 5 insertions, 3 deletions
diff --git a/sysutils/xen-tools/Makefile b/sysutils/xen-tools/Makefile
index 4a12005c08ed..789b38af614a 100644
--- a/sysutils/xen-tools/Makefile
+++ b/sysutils/xen-tools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xen
PKGNAMESUFFIX= -tools
PORTVERSION= 4.14.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= sysutils emulators
MASTER_SITES= http://downloads.xenproject.org/release/xen/${PORTVERSION}/
@@ -35,7 +35,7 @@ ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than amd64"
USES= cpe gettext gmake gnome libtool localbase:ldflags perl5 \
- pkgconfig python shebangfix iconv bison
+ pkgconfig python:3.6+ shebangfix iconv bison
USE_GNOME= glib20
USE_LDCONFIG= yes
USE_PYTHON= py3kplist
@@ -43,6 +43,8 @@ HAS_CONFIGURE= yes
# Set ARCH=x86_64 in order to overwrite the environment ARCH=amd64
MAKE_ARGS= clang=y ARCH=x86_64
+BINARY_ALIAS= python3=${PYTHON_CMD}
+
CONFIGURE_ARGS+= --with-system-seabios=${LOCALBASE}/share/seabios/bios.bin \
--mandir=${MANPREFIX}/man
diff --git a/sysutils/xen-tools/pkg-plist b/sysutils/xen-tools/pkg-plist
index ce4ac757b52b..f5871124f90a 100644
--- a/sysutils/xen-tools/pkg-plist
+++ b/sysutils/xen-tools/pkg-plist
@@ -209,7 +209,7 @@ lib/libxlutil.so.4.14.0
%%PYTHON_SITELIBDIR%%/xen-3.0-py%%PYTHON_VER%%.egg-info
%%PYTHON_SITELIBDIR%%/xen/__init__.py
%%PYTHON_SITELIBDIR%%/xen/__init__.pyc
-%%PYTHON_SITELIBDIR%%/xen/__pycache__/util.cpython-37.pyc
+%%PYTHON_SITELIBDIR%%/xen/__pycache__/util.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.py
%%PYTHON_SITELIBDIR%%/xen/lowlevel/__init__.pyc
%%PYTHON_SITELIBDIR%%/xen/lowlevel/xc.so