aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-battery-plugin/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-17 15:46:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-17 15:46:49 +0000
commit9fc8f267f405bda41b14ea8d0020c5e5e02938ae (patch)
tree02c4c63efcb44801c23dfc8944f6ce99093353a1 /sysutils/xfce4-battery-plugin/Makefile
parentd9106b3dbac84a14015c7d5df3c3a4fc7bcd349c (diff)
downloadports-9fc8f267f405bda41b14ea8d0020c5e5e02938ae.tar.gz
ports-9fc8f267f405bda41b14ea8d0020c5e5e02938ae.zip
Notes
Diffstat (limited to 'sysutils/xfce4-battery-plugin/Makefile')
-rw-r--r--sysutils/xfce4-battery-plugin/Makefile27
1 files changed, 21 insertions, 6 deletions
diff --git a/sysutils/xfce4-battery-plugin/Makefile b/sysutils/xfce4-battery-plugin/Makefile
index 437475bf31ca..267c428a3fcf 100644
--- a/sysutils/xfce4-battery-plugin/Makefile
+++ b/sysutils/xfce4-battery-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xfce4-battery-plugin
-PORTVERSION= 0.5.1
-PORTREVISION= 9
+PORTVERSION= 1.0.0
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -18,11 +17,27 @@ COMMENT= Battery monitor panel plugin for XFce4
ONLY_FOR_ARCHS= i386 amd64
+USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv panel
+USE_GNOME= gnomehack gtk20 glib20 intltool intlhack pkgconfig
+USE_XFCE= configenv libgui libutil panel
+INSTALLS_ICONS= yes
+
+CONFIGURE_ARGS= --disable-debug
+
+OPTIONS= NLS "Enable Native Language Support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>