aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-genmon-plugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-04-12 02:31:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-04-12 02:31:09 +0000
commit7c80d0685453a132e52916e92cc844d7490d7d27 (patch)
tree8fd8b61f186621e2141e769816a1fd48c159f90b /sysutils/xfce4-genmon-plugin
parent37a092dac2124067b376744f57c947040c882b41 (diff)
downloadports-7c80d0685453a132e52916e92cc844d7490d7d27.tar.gz
ports-7c80d0685453a132e52916e92cc844d7490d7d27.zip
- Update to 3.3.0
PR: 155966 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com
Notes
Notes: svn path=/head/; revision=272557
Diffstat (limited to 'sysutils/xfce4-genmon-plugin')
-rw-r--r--sysutils/xfce4-genmon-plugin/Makefile15
-rw-r--r--sysutils/xfce4-genmon-plugin/distinfo4
-rw-r--r--sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__cmdspawn.c33
-rw-r--r--sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__main.c32
-rw-r--r--sysutils/xfce4-genmon-plugin/pkg-plist29
5 files changed, 35 insertions, 78 deletions
diff --git a/sysutils/xfce4-genmon-plugin/Makefile b/sysutils/xfce4-genmon-plugin/Makefile
index 76b0107c480f..f8a5c907e53b 100644
--- a/sysutils/xfce4-genmon-plugin/Makefile
+++ b/sysutils/xfce4-genmon-plugin/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= xfce4-genmon-plugin
-PORTVERSION= 3.2
-PORTREVISION= 11
+PORTVERSION= 3.3.0
CATEGORIES= sysutils xfce
-MASTER_SITES= CRITICAL/xfce4
+MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= miwi@FreeBSD.org
@@ -19,12 +19,9 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv libutil libgui panel
+USE_GNOME= gnomehack gtk20 intltool intlhack pkgconfig
+USE_XFCE= configenv libgui panel
-post-patch:
- @${REINPLACE_CMD} -e 's|--libs "libxfce4panel-1.0"|& "libxfcegui4-1.0"|g; \
- s|--cflags "libxfce4panel-1.0"|& "libxfcegui4-1.0"|g' \
- ${WRKSRC}/configure
+CONFIGURE_ENV+= ac_cv_prog_AWK="${AWK}"
.include <bsd.port.mk>
diff --git a/sysutils/xfce4-genmon-plugin/distinfo b/sysutils/xfce4-genmon-plugin/distinfo
index 21eace0c4968..18567ab3e707 100644
--- a/sysutils/xfce4-genmon-plugin/distinfo
+++ b/sysutils/xfce4-genmon-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfce4-genmon-plugin-3.2.tar.bz2) = b2c15d4745092321f4c502123dba58fded6d80f4c2ade4e819fd65eaa541c133
-SIZE (xfce4/xfce4-genmon-plugin-3.2.tar.bz2) = 142540
+SHA256 (xfce4/xfce4-genmon-plugin-3.3.0.tar.bz2) = 56cf632c196cf988cef36c3965651e9fd9c838c21c133d643e3563e18f45e7c0
+SIZE (xfce4/xfce4-genmon-plugin-3.3.0.tar.bz2) = 125754
diff --git a/sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__cmdspawn.c b/sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__cmdspawn.c
deleted file mode 100644
index a7a3480187b2..000000000000
--- a/sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__cmdspawn.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- ./panel-plugin/cmdspawn.c.orig 2007-11-23 16:32:40.000000000 +0100
-+++ ./panel-plugin/cmdspawn.c 2010-11-07 11:29:03.000000000 +0100
-@@ -184,6 +184,7 @@
- return (-1);
- case 0:
- /* Redirect stdout/stderr to associated pipe's write-ends */
-+ close(0); /* stdin is not used in child */
- for (i = 0; i < OUT_ERR; i++) {
- j = i + 1; // stdout/stderr file descriptor
- close (j);
-@@ -199,6 +200,9 @@
- exit (-1);
- }
-
-+ for (i = 0; i < OUT_ERR; i++)
-+ close (aaiPipe[i][WR]); /* close write end of pipes in parent */
-+
- /* Wait for child completion */
- if (wait == 1)
- {
-@@ -231,10 +235,9 @@
- }
-
- End:
-- /* Close created pipes */
-+ /* Close read end of pipes */
- for (i = 0; i < OUT_ERR; i++)
-- for (j = 0; j < RD_WR; j++)
-- close (aaiPipe[i][j]);
-+ close (aaiPipe[i][RD]);
-
- return (-fError);
- }// Spawn()
diff --git a/sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__main.c b/sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__main.c
deleted file mode 100644
index d2491de0a1b7..000000000000
--- a/sysutils/xfce4-genmon-plugin/files/patch-panel-plugin__main.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- ./panel-plugin/main.c.orig 2008-03-15 23:38:18.000000000 +0100
-+++ ./panel-plugin/main.c 2010-11-07 11:28:17.000000000 +0100
-@@ -32,6 +32,7 @@
-
- #include <libxfce4util/libxfce4util.h>
- #include <libxfcegui4/dialogs.h>
-+#include <libxfcegui4/xfce-exec.h>
- #include <libxfce4panel/xfce-panel-plugin.h>
- #include <libxfce4panel/xfce-panel-convenience.h>
-
-@@ -94,10 +95,18 @@
- {
- struct genmon_t *poPlugin = (genmon_t *) p_pvPlugin;
- struct monitor_t *poMonitor = &(poPlugin->oMonitor);
-- char result[256];
-+ GError *error = NULL;
-+
-+ xfce_exec(poMonitor->onClickCmd, 0, 0, &error);
-+ if (error) {
-+ char first[256];
-+ g_snprintf (first, sizeof(first), _("Could not run \"%s\""), poMonitor->onClickCmd);
-+ xfce_message_dialog (NULL, _("Xfce Panel"),
-+ GTK_STOCK_DIALOG_ERROR, first, error->message,
-+ GTK_STOCK_CLOSE, GTK_RESPONSE_OK, NULL);
-+ g_error_free (error);
-+ }
-
-- genmon_SpawnCmd (poMonitor->onClickCmd, result,
-- sizeof (poMonitor->onClickCmd), 0);
- }
-
- /**************************************************************/
diff --git a/sysutils/xfce4-genmon-plugin/pkg-plist b/sysutils/xfce4-genmon-plugin/pkg-plist
index 574bc7366ae7..730794f99427 100644
--- a/sysutils/xfce4-genmon-plugin/pkg-plist
+++ b/sysutils/xfce4-genmon-plugin/pkg-plist
@@ -1,19 +1,44 @@
libexec/xfce4/panel-plugins/xfce4-genmon-plugin
+share/locale/ast/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/ca/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/cs/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/da/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/de/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/el/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/en_GB/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/es/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/eu/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/fr/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/gl/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/hu/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/id/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/it/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/ja/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/kk/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/lv/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/pl/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/pt/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/pt_BR/LC_MESSAGES/xfce4-genmon-plugin.mo
-share/locale/pt_PT/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/ru/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/sq/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/sv/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/tr/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/ug/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/uk/LC_MESSAGES/xfce4-genmon-plugin.mo
share/locale/ur/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/ur_PK/LC_MESSAGES/xfce4-genmon-plugin.mo
+share/locale/zh_CN/LC_MESSAGES/xfce4-genmon-plugin.mo
share/xfce4/panel-plugins/genmon.desktop
@dirrmtry share/xfce4/panel-plugins
-@dirrmtry share/xfce4
+@dirrmtry share/locale/ur_PK/LC_MESSAGES
+@dirrmtry share/locale/ur_PK
@dirrmtry share/locale/ur/LC_MESSAGES
@dirrmtry share/locale/ur
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry libexec/xfce4/panel-plugins
@dirrmtry libexec/xfce4