aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-settings
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-01-10 15:33:03 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-01-10 15:33:03 +0000
commitf847247fe08d92ef708296d09071c39a55271a35 (patch)
tree9009785b99feb15dd1fe0a24db3582c3055e0ba4 /sysutils/xfce4-settings
parenta6c46a5ec5c6b2693ae0594f981d3505c622e2a6 (diff)
downloadports-f847247fe08d92ef708296d09071c39a55271a35.tar.gz
ports-f847247fe08d92ef708296d09071c39a55271a35.zip
- Fix script used to extract themes to fallback to /tmp when both
TMPDIR and XDG_CACHE_HOME environment variables are not defined [1] - Fix crash caused by null terminated list missing the terminating null element due to no allocating enough elements [2] Reported by: Andrea Venturoli <ml@netfence.it> [1] [2] Patch submitted by: Andrea Venturoli <ml@netfence.it> [2] MFH: 2021Q1
Notes
Notes: svn path=/head/; revision=561081
Diffstat (limited to 'sysutils/xfce4-settings')
-rw-r--r--sysutils/xfce4-settings/Makefile1
-rw-r--r--sysutils/xfce4-settings/files/patch-dialogs_appearance-settings_appearance-install-theme10
-rw-r--r--sysutils/xfce4-settings/files/patch-dialogs_appearance-settings_main.c11
3 files changed, 22 insertions, 0 deletions
diff --git a/sysutils/xfce4-settings/Makefile b/sysutils/xfce4-settings/Makefile
index 8f5f59dc3ea5..0ab3a0fe054d 100644
--- a/sysutils/xfce4-settings/Makefile
+++ b/sysutils/xfce4-settings/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xfce4-settings
PORTVERSION= 4.16.0
+PORTREVISION= 1
CATEGORIES= sysutils xfce
MASTER_SITES= XFCE
DIST_SUBDIR= xfce4
diff --git a/sysutils/xfce4-settings/files/patch-dialogs_appearance-settings_appearance-install-theme b/sysutils/xfce4-settings/files/patch-dialogs_appearance-settings_appearance-install-theme
new file mode 100644
index 000000000000..2bac50f627ad
--- /dev/null
+++ b/sysutils/xfce4-settings/files/patch-dialogs_appearance-settings_appearance-install-theme
@@ -0,0 +1,10 @@
+--- dialogs/appearance-settings/appearance-install-theme.orig 2015-08-01 08:43:16 UTC
++++ dialogs/appearance-settings/appearance-install-theme
+@@ -104,6 +104,7 @@ fi
+ # we try $XDG_CACHE_HOME because it is more likely this is on the
+ # same partition, so moving the theme after extract is faster
+ if test x"`which mktemp 2>/dev/null`" != x""; then
++ TMPDIR="${TMPDIR:-/tmp}"
+ tmpdir=`TMPDIR="${XDG_CACHE_HOME:-$TMPDIR}" mktemp -d`
+ else
+ tmpdir="/tmp/tmp.$$.$RANDOM"
diff --git a/sysutils/xfce4-settings/files/patch-dialogs_appearance-settings_main.c b/sysutils/xfce4-settings/files/patch-dialogs_appearance-settings_main.c
new file mode 100644
index 000000000000..d7f7ca22cde7
--- /dev/null
+++ b/sysutils/xfce4-settings/files/patch-dialogs_appearance-settings_main.c
@@ -0,0 +1,11 @@
+--- dialogs/appearance-settings/main.c.orig 2020-12-16 10:44:46 UTC
++++ dialogs/appearance-settings/main.c
+@@ -994,7 +994,7 @@ appearance_settings_install_theme_cb (GtkButton *widge
+ gchar **uris;
+ GtkFileChooser *chooser = GTK_FILE_CHOOSER (dialog);
+
+- uris = g_new0 (gchar *, 1);
++ uris = g_new0 (gchar *, 2);
+ filename = gtk_file_chooser_get_filename (chooser);
+ uris[0] = g_filename_to_uri (filename, NULL, NULL);
+ install_theme (window, uris, builder);