aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-systemload-plugin
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2012-07-18 18:46:28 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2012-07-18 18:46:28 +0000
commit4a1352c002dc8d0cb55e6104af9f5414c784e1af (patch)
treedbcd28ff7e5eff3afc50924070db4be97f0cf486 /sysutils/xfce4-systemload-plugin
parentcc4adc8b7acebfe362eca70c5cc2cd55e751f1a0 (diff)
downloadports-4a1352c002dc8d0cb55e6104af9f5414c784e1af.tar.gz
ports-4a1352c002dc8d0cb55e6104af9f5414c784e1af.zip
- Update to 1.1.1
- Convert to new options framework - Assign maintainance to xfce@ team PR: 168789 (update to 1.1.0) Submitted by: myself Approved by: miwi, rene (mentors), maintainer timeout (> 2 weeks)
Notes
Notes: svn path=/head/; revision=301115
Diffstat (limited to 'sysutils/xfce4-systemload-plugin')
-rw-r--r--sysutils/xfce4-systemload-plugin/Makefile21
-rw-r--r--sysutils/xfce4-systemload-plugin/distinfo4
-rw-r--r--sysutils/xfce4-systemload-plugin/files/patch-panel-plugin__memswap.c13
-rw-r--r--sysutils/xfce4-systemload-plugin/files/patch-panel-plugin__uptime.c11
-rw-r--r--sysutils/xfce4-systemload-plugin/pkg-plist16
5 files changed, 23 insertions, 42 deletions
diff --git a/sysutils/xfce4-systemload-plugin/Makefile b/sysutils/xfce4-systemload-plugin/Makefile
index 752e70cdbd26..e3295b904046 100644
--- a/sysutils/xfce4-systemload-plugin/Makefile
+++ b/sysutils/xfce4-systemload-plugin/Makefile
@@ -6,30 +6,29 @@
#
PORTNAME= xfce4-systemload-plugin
-PORTVERSION= 1.0.0
-PORTREVISION= 4
+PORTVERSION= 1.1.1
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
-MAINTAINER= thorsten.greiner@web.de
+MAINTAINER= xfce@FreeBSD.org
COMMENT= System Load plugin for XFce4
-USE_AUTOTOOLS= libtool
+LIB_DEPENDS= upower-glib.1:${PORTSDIR}/sysutils/upower
+
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv libgui panel
-
-CONFIGURE_ARGS= --disable-debug
+USE_XFCE= configenv libmenu libutil panel
-OPTIONS= NLS "Enable Native Language Support" on
+OPTIONS_DEFINE= NLS
+OPTIONS_DEFAULT= NLS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -38,4 +37,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/xfce4-systemload-plugin/distinfo b/sysutils/xfce4-systemload-plugin/distinfo
index 25724d065eb9..37b97cd3835b 100644
--- a/sysutils/xfce4-systemload-plugin/distinfo
+++ b/sysutils/xfce4-systemload-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfce4-systemload-plugin-1.0.0.tar.bz2) = 4a2ffe49572105e301b5bf6666fff9e48126f1ef7e5fbed9f4b495fd48c192f9
-SIZE (xfce4/xfce4-systemload-plugin-1.0.0.tar.bz2) = 305892
+SHA256 (xfce4/xfce4-systemload-plugin-1.1.1.tar.bz2) = 1ac13efbe9e576c9effd5e0675574a57c8fd44cfee60d6e319eb4d03c1c8d9ae
+SIZE (xfce4/xfce4-systemload-plugin-1.1.1.tar.bz2) = 299695
diff --git a/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin__memswap.c b/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin__memswap.c
deleted file mode 100644
index 9535a847d353..000000000000
--- a/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin__memswap.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./panel-plugin/memswap.c.orig 2010-12-09 19:04:10.000000000 +0300
-+++ ./panel-plugin/memswap.c 2011-07-03 15:39:52.384882846 +0400
-@@ -228,8 +228,8 @@
- return -1;
- }
-
-- *MT = (total_pages*pagesize) >> 10;
-- *MU = ((total_pages-free_pages-inactive_pages) * pagesize) >> 10;
-+ *MT = CONVERT(total_pages);
-+ *MU = CONVERT(total_pages-free_pages-inactive_pages);
- *mem = *MU * 100 / *MT;
-
- if((*swap = swapmode(&swap_avail, &swap_free)) >= 0) {
diff --git a/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin__uptime.c b/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin__uptime.c
deleted file mode 100644
index db8def93a577..000000000000
--- a/sysutils/xfce4-systemload-plugin/files/patch-panel-plugin__uptime.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./panel-plugin/uptime.c.orig 2010-12-09 19:04:10.000000000 +0300
-+++ ./panel-plugin/uptime.c 2011-07-03 15:39:52.391879944 +0400
-@@ -93,7 +93,7 @@
- int mib[2] = {CTL_KERN, KERN_BOOTTIME};
- struct timeval boottime;
- time_t now;
-- int size = sizeof(boottime);
-+ size_t size = sizeof(boottime);
- gulong uptime;
-
- if((sysctl(mib, 2, &boottime, &size, NULL, 0) != -1)
diff --git a/sysutils/xfce4-systemload-plugin/pkg-plist b/sysutils/xfce4-systemload-plugin/pkg-plist
index 03e264a01eb8..d15466020a62 100644
--- a/sysutils/xfce4-systemload-plugin/pkg-plist
+++ b/sysutils/xfce4-systemload-plugin/pkg-plist
@@ -1,15 +1,18 @@
-libexec/xfce4/panel-plugins/xfce4-systemload-plugin
+lib/xfce4/panel/plugins/libsystemload.la
+lib/xfce4/panel/plugins/libsystemload.so
%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/cs/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/da/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/de/LC_MESSAGES/xfce4-systemload-plugin.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/es/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-systemload-plugin.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/id/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/it/LC_MESSAGES/xfce4-systemload-plugin.mo
@@ -23,6 +26,7 @@ libexec/xfce4/panel-plugins/xfce4-systemload-plugin
%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-systemload-plugin.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-systemload-plugin.mo
@@ -33,8 +37,9 @@ libexec/xfce4/panel-plugins/xfce4-systemload-plugin
%%NLS%%share/locale/vi/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-systemload-plugin.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-systemload-plugin.mo
-share/xfce4/panel-plugins/systemload.desktop
-@dirrmtry share/xfce4/panel-plugins
+share/xfce4/panel/plugins/systemload.desktop
+@dirrmtry share/xfce4/panel/plugins
+@dirrmtry share/xfce4/panel
@dirrmtry share/xfce4
%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ur_PK
@@ -44,5 +49,6 @@ share/xfce4/panel-plugins/systemload.desktop
%%NLS%%@dirrmtry share/locale/ug
%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ast
-@dirrmtry libexec/xfce4/panel-plugins
-@dirrmtry libexec/xfce4
+@dirrmtry lib/xfce4/panel/plugins
+@dirrmtry lib/xfce4/panel
+@dirrmtry lib/xfce4