aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-systemload-plugin
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-09-27 08:53:03 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-09-27 08:53:03 +0000
commit5cd8c20912017f1deb8ec69ea37ba93cb81856d9 (patch)
treee27fde8c703dd600f2c655fd1101efbf800b9934 /sysutils/xfce4-systemload-plugin
parent342bf512ba9728a8a57dcdda1250393b46afa5d3 (diff)
downloadports-5cd8c20912017f1deb8ec69ea37ba93cb81856d9.tar.gz
ports-5cd8c20912017f1deb8ec69ea37ba93cb81856d9.zip
- Add UPOWER option to xfce4-systemload-plugin, enabled by default
since it was mandatory before [1] - While here cleanup and silence one portlint warning PR: 231731 [1] Submitted by: Ali Abdallah <aliovx@gmail.com>
Notes
Notes: svn path=/head/; revision=480791
Diffstat (limited to 'sysutils/xfce4-systemload-plugin')
-rw-r--r--sysutils/xfce4-systemload-plugin/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/sysutils/xfce4-systemload-plugin/Makefile b/sysutils/xfce4-systemload-plugin/Makefile
index ee79c60865e0..811ad7588441 100644
--- a/sysutils/xfce4-systemload-plugin/Makefile
+++ b/sysutils/xfce4-systemload-plugin/Makefile
@@ -12,19 +12,23 @@ COMMENT= System Load plugin for Xfce4 panel
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libupower-glib.so:sysutils/upower
+USES= gettext-tools gmake libtool pkgconfig tar:bzip2 xfce:gtk3
+USE_GNOME= gtk30 intltool cairo gdkpixbuf2
+USE_XFCE= panel
SSP_UNSAFE= yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gettext-tools gmake libtool pkgconfig tar:bzip2 xfce:gtk3
-USE_GNOME= gtk30 intltool cairo gdkpixbuf2
-USE_XFCE= panel
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= NLS UPOWER
+OPTIONS_DEFAULT=UPOWER
+UPOWER_DESC= Use upower for adapting update interval to power state
OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
+UPOWER_CONFIGURE_ENABLE=upower
+UPOWER_LIB_DEPENDS= libupower-glib.so:sysutils/upower
+
.include <bsd.port.mk>