aboutsummaryrefslogtreecommitdiff
path: root/sysutils/zbackup/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-14 17:58:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-14 17:58:31 +0000
commite9e401c503c2f701559994f77b16a08da22862ad (patch)
tree2ac559a1ff3d7646419bb6c2553d7c4ff52c2f9a /sysutils/zbackup/Makefile
parent81196f870c234657216cc9daccece565e58956ff (diff)
- Fix build with protobuf 3.1.0
- Bump PORTREVISION for devel/protobuf shlib change - While I'm here, add missing USES=ssl
Notes
Notes: svn path=/head/; revision=428583
Diffstat (limited to 'sysutils/zbackup/Makefile')
-rw-r--r--sysutils/zbackup/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/sysutils/zbackup/Makefile b/sysutils/zbackup/Makefile
index d544e941ce6d..3b284e9653d5 100644
--- a/sysutils/zbackup/Makefile
+++ b/sysutils/zbackup/Makefile
@@ -2,6 +2,7 @@
PORTNAME= zbackup
PORTVERSION= 1.4.4
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://github.com/zbackup/zbackup/archive/
DISTNAME= ${PORTVERSION}
@@ -14,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libprotobuf.so:devel/protobuf \
liblzo2.so:archivers/lzo2
-USES= alias cmake
+USES= alias cmake ssl
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -23,6 +24,9 @@ OPTIONS_DEFINE= DOCS
PLIST_FILES= bin/zbackup
PORTDOCS= README.md
+post-patch:
+ @${REINPLACE_CMD} -e 's| CHECK(| ZBACKUP_CHECK(|' ${WRKSRC}/*.cc ${WRKSRC}/*.hh ${WRKSRC}/tests/*/*.cc
+
do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}