aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-08-07 03:26:06 +0000
committerCy Schubert <cy@FreeBSD.org>2016-08-07 03:26:06 +0000
commit107dd7651c4dcca186209bd4bd610a8b56f40f03 (patch)
treeae7aae18791426a0038aab1eb8841307ab392b81 /sysutils
parent06aa50f33c79717ba6d6b4fdb2cd8895c438a955 (diff)
downloadports-107dd7651c4dcca186209bd4bd610a8b56f40f03.tar.gz
ports-107dd7651c4dcca186209bd4bd610a8b56f40f03.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cfengine39/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/sysutils/cfengine39/Makefile b/sysutils/cfengine39/Makefile
index 22d843a3757f..2c2aff55bf5b 100644
--- a/sysutils/cfengine39/Makefile
+++ b/sysutils/cfengine39/Makefile
@@ -28,10 +28,10 @@ USE_RC_SUBR= cf-execd cf-serverd cf-monitord
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
USES= autoreconf:build \
- cpe gmake libtool shebangfix
+ cpe gmake libtool shebangfix ssl
+USE_GNOME= libxml2
SHEBANG_FILES= examples/remake_outputs.pl
CFLAGS+= -Wno-return-type
CPPFLAGS+= -I${LOCALBASE}/include
@@ -52,14 +52,16 @@ CONFIGURE_ARGS= --docdir=${DOCSDIR} \
INSTALL_TARGET= install-strip
LIB_DEPENDS+= libpcre.so:devel/pcre \
- liblmdb.so:databases/lmdb
+ liblmdb.so:databases/lmdb \
+ libyaml.so:textproc/libyaml \
+ libcurl.so:ftp/curl
OPTIONS_DEFINE= PGSQL MYSQL LIBVIRT
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql