aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-04-19 14:28:34 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-04-19 14:29:56 +0000
commit1b6314a7773b47e18f5da903035bca74a235f35c (patch)
treef825b0d84af645882d90b8032ac43f296632944f /sysutils
parent8d23ff30e4ef22d7901e5403e979ec86a4671e54 (diff)
downloadports-1b6314a7773b47e18f5da903035bca74a235f35c.tar.gz
ports-1b6314a7773b47e18f5da903035bca74a235f35c.zip
sysutils/herbe: Add a new port: Daemon-less notifications without D-Bus
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/herbe/Makefile37
-rw-r--r--sysutils/herbe/distinfo3
-rw-r--r--sysutils/herbe/pkg-descr13
4 files changed, 54 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 76e17bb02227..9f75ea793ef3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -481,6 +481,7 @@
SUBDIR += heirloom
SUBDIR += helm
SUBDIR += helmfile
+ SUBDIR += herbe
SUBDIR += hexpeek
SUBDIR += hextools
SUBDIR += hexyl
diff --git a/sysutils/herbe/Makefile b/sysutils/herbe/Makefile
new file mode 100644
index 000000000000..23c453de7bb3
--- /dev/null
+++ b/sysutils/herbe/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= herbe
+DISTVERSION= 1.0.0
+CATEGORIES= sysutils
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Daemon-less notifications without D-Bus
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/freetype2/ft2build.h:print/freetype2
+
+USES= localbase xorg
+
+USE_GITHUB= yes
+GH_ACCOUNT= dudik
+
+USE_XORG= x11 xft
+
+MAKE_ARGS= CFLAGS="${CFLAGS} ${LIBS}"
+
+CFLAGS+= -I${LOCALBASE}/include/freetype2
+LIBS+= -lX11 -lXft
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/herbe/distinfo b/sysutils/herbe/distinfo
new file mode 100644
index 000000000000..0fad29d892f8
--- /dev/null
+++ b/sysutils/herbe/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1618841765
+SHA256 (dudik-herbe-1.0.0_GH0.tar.gz) = 78e454159050c86e030fb5a6cf997ac914345210cdf5a4ca4d7600c5296b7f76
+SIZE (dudik-herbe-1.0.0_GH0.tar.gz) = 4974
diff --git a/sysutils/herbe/pkg-descr b/sysutils/herbe/pkg-descr
new file mode 100644
index 000000000000..21f938597282
--- /dev/null
+++ b/sysutils/herbe/pkg-descr
@@ -0,0 +1,13 @@
+herbe provides daemon-less notifications without D-Bus. It's meant to be
+minimal and lightweight.
+
+Some of its features are:
+
+- Under 200 lines of code
+- Doesn't run in the background, just displays the notification and exits
+- No external dependencies except Xlib and Xft
+- Configurable through config.h or Xresources
+- Actions support
+- Extensible through patches
+
+WWW: https://github.com/dudik/herbe