aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-04-20 10:51:23 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2021-04-20 10:52:14 +0000
commit21c95a179f0b45670469c2d5dc8ba22014a8159b (patch)
tree4df2e83d123753f11e95c2ae928269bf12ad2479 /sysutils
parent45a4d45b166acd6956d4fb3ed7910a518c4595e4 (diff)
downloadports-21c95a179f0b45670469c2d5dc8ba22014a8159b.tar.gz
ports-21c95a179f0b45670469c2d5dc8ba22014a8159b.zip
sysutils/py-pytsk: update to 20210327
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/py-pytsk/Makefile19
-rw-r--r--sysutils/py-pytsk/distinfo6
-rw-r--r--sysutils/py-pytsk/files/patch-setup.py43
3 files changed, 10 insertions, 58 deletions
diff --git a/sysutils/py-pytsk/Makefile b/sysutils/py-pytsk/Makefile
index a883822c75a3..6230c5a9fd48 100644
--- a/sysutils/py-pytsk/Makefile
+++ b/sysutils/py-pytsk/Makefile
@@ -1,10 +1,10 @@
# Created by: Antoine Brodin <antoine@FreeBSD.org>
PORTNAME= pytsk
-PORTVERSION= 20200117
+PORTVERSION= 20210327
CATEGORIES= sysutils security devel python
-MASTER_SITES= CHEESESHOP
-# https://github.com/py4n6/pytsk/releases/download/${PORTVERSION}/
+MASTER_SITES= https://github.com/py4n6/pytsk/releases/download/${PORTVERSION}/ \
+ LOCAL/antoine
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}3-${PORTVERSION}
@@ -14,16 +14,11 @@ COMMENT= Python bindings for the Sleuthkit
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libtalloc.so:devel/talloc \
- libtsk.so:sysutils/sleuthkit
-
-USES= python:3.5+
+USES= python:3.6+
USE_PYTHON= distutils autoplist
-post-extract:
- ${RM} ${WRKSRC}/pytsk3.c
-
-post-patch:
- ${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/setup.py
+DO_MAKE_TEST= ${SETENV} ${TEST_ENV} ${PYTHON_CMD} run_tests.py
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+TEST_TARGET= # empty
.include <bsd.port.mk>
diff --git a/sysutils/py-pytsk/distinfo b/sysutils/py-pytsk/distinfo
index 016ec8273ebd..9b8f07c32733 100644
--- a/sysutils/py-pytsk/distinfo
+++ b/sysutils/py-pytsk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1579428967
-SHA256 (pytsk3-20200117.tar.gz) = 56177164a358e98baa258296aa2e9a509304dc8dab053abac347435a0978d962
-SIZE (pytsk3-20200117.tar.gz) = 3060827
+TIMESTAMP = 1616918215
+SHA256 (pytsk3-20210327.tar.gz) = 8c48c5ad24668af52a524e2fb7bd005a3bb4087c59e15a0341f75a1279160e96
+SIZE (pytsk3-20210327.tar.gz) = 3082961
diff --git a/sysutils/py-pytsk/files/patch-setup.py b/sysutils/py-pytsk/files/patch-setup.py
deleted file mode 100644
index 0a9f0e76815f..000000000000
--- a/sysutils/py-pytsk/files/patch-setup.py
+++ /dev/null
@@ -1,43 +0,0 @@
-# Unbundle sleuthkit and talloc
-
---- setup.py.orig 2020-01-17 19:49:31 UTC
-+++ setup.py
-@@ -245,9 +245,9 @@ class BuildExtCommand(build_ext):
- def run(self):
- compiler = new_compiler(compiler=self.compiler)
- # pylint: disable=attribute-defined-outside-init
-- self.define = self.configure_source_tree(compiler)
-+ self.define = [("HAVE_TSK_LIBTSK_H", "")]
-
-- libtsk_path = os.path.join("sleuthkit", "tsk")
-+ libtsk_path = os.path.join("%%LOCALBASE%%", "include", "tsk")
-
- if not os.access("pytsk3.c", os.R_OK):
- # Generate the Python binding code (pytsk3.c).
-@@ -409,7 +409,7 @@ class ProjectBuilder(object):
- self._argv = argv
-
- # The path to the sleuthkit/tsk directory.
-- self._libtsk_path = os.path.join("sleuthkit", "tsk")
-+ self._libtsk_path = os.path.join("%%LOCALBASE%%", "include", "tsk")
-
- # Paths under the sleuthkit/tsk directory which contain files we need
- # to compile.
-@@ -418,13 +418,13 @@ class ProjectBuilder(object):
- # The args for the extension builder.
- self.extension_args = {
- "define_macros": [],
-- "include_dirs": ["talloc", self._libtsk_path, "sleuthkit", "."],
-- "library_dirs": [],
-- "libraries": []}
-+ "include_dirs": [".", os.path.join("%%LOCALBASE%%", "include")],
-+ "library_dirs": [os.path.join("%%LOCALBASE%%","lib")],
-+ "libraries": ["tsk", "talloc"]}
-
- # The sources to build.
- self._source_files = [
-- "class.c", "error.c", "tsk3.c", "pytsk3.c", "talloc/talloc.c"]
-+ "class.c", "error.c", "tsk3.c", "pytsk3.c"]
-
- # Path to the top of the unpacked sleuthkit sources.
- self._sleuthkit_path = "sleuthkit"