aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-02-10 22:39:15 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-02-10 22:39:15 +0000
commit266bf590e7288dbb2bb055db228d44c908a487f4 (patch)
tree69e35bd4241ffc8daf9d153d1e445d0d75da899a /sysutils
parentebd1d0d016a99535e03ecb86446c57934d833e7e (diff)
downloadports-266bf590e7288dbb2bb055db228d44c908a487f4.tar.gz
ports-266bf590e7288dbb2bb055db228d44c908a487f4.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/py-azure-cli/Makefile2
-rw-r--r--sysutils/py-azure-cli/distinfo6
-rw-r--r--sysutils/py-azure-cli/files/patch-azure_cli_command__modules_storage_azcopy_util.py22
3 files changed, 15 insertions, 15 deletions
diff --git a/sysutils/py-azure-cli/Makefile b/sysutils/py-azure-cli/Makefile
index 32c00f0f5f77..164abb75ceec 100644
--- a/sysutils/py-azure-cli/Makefile
+++ b/sysutils/py-azure-cli/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= azure-cli
-PORTVERSION= 2.0.80
+PORTVERSION= 2.0.81
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/sysutils/py-azure-cli/distinfo b/sysutils/py-azure-cli/distinfo
index 33d90b7b1bb0..9dcc12b9f3e6 100644
--- a/sysutils/py-azure-cli/distinfo
+++ b/sysutils/py-azure-cli/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1579218897
-SHA256 (azure-cli-2.0.80.tar.gz) = cbc17396e5e6cb58bddedb1b125daabd8112557f732c35a4d924378e5e78f630
-SIZE (azure-cli-2.0.80.tar.gz) = 1155965
+TIMESTAMP = 1581281581
+SHA256 (azure-cli-2.0.81.tar.gz) = 85de3dc3973be295d1bc09359bbbd133fde73a370f10ec24d9c152b4ff519467
+SIZE (azure-cli-2.0.81.tar.gz) = 1187545
diff --git a/sysutils/py-azure-cli/files/patch-azure_cli_command__modules_storage_azcopy_util.py b/sysutils/py-azure-cli/files/patch-azure_cli_command__modules_storage_azcopy_util.py
index 676bcf4e35a4..647ea116904a 100644
--- a/sysutils/py-azure-cli/files/patch-azure_cli_command__modules_storage_azcopy_util.py
+++ b/sysutils/py-azure-cli/files/patch-azure_cli_command__modules_storage_azcopy_util.py
@@ -1,15 +1,15 @@
---- azure/cli/command_modules/storage/azcopy/util.py.orig 2019-12-04 23:30:55 UTC
+--- azure/cli/command_modules/storage/azcopy/util.py.orig 2020-01-31 12:42:39 UTC
+++ azure/cli/command_modules/storage/azcopy/util.py
-@@ -41,6 +41,8 @@ class AzCopy(object):
- file_url = base_url.format('linux', 'tar.gz')
- elif self.system == 'Darwin':
- file_url = base_url.format('darwin', 'zip')
-+ elif self.system == 'FreeBSD':
-+ raise CLIError('Azcopy ({}) binary not available, follow instructions at https://wiki.freebsd.org/Ports/sysutils/py-azure-cli'.format(self.system))
- else:
- raise CLIError('Azcopy ({}) does not exist.'.format(self.system))
- try:
-@@ -163,7 +165,7 @@ def _get_default_install_location():
+@@ -50,6 +50,8 @@ class AzCopy(object):
+ file_url = base_url.format('linux', 'amd64', AZCOPY_VERSION, 'tar.gz')
+ elif self.system == 'Darwin':
+ file_url = base_url.format('darwin', 'amd64', AZCOPY_VERSION, 'zip')
++ elif self.system == 'FreeBSD':
++ raise CLIError('Azcopy ({}) binary not available, follow instructions at https://wiki.freebsd.org/Ports/sysutils/py-azure-cli'.format(self.system))
+ else:
+ raise CLIError('Azcopy ({}) does not exist.'.format(self.system))
+ try:
+@@ -180,7 +182,7 @@ def _get_default_install_location():
if not home_dir:
return None
install_location = os.path.join(home_dir, r'.azcopy\azcopy.exe')