aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2012-08-09 19:29:22 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2012-08-09 19:29:22 +0000
commit3f1a947dcfa6c212696c1b4e11e79d2f089d4b7d (patch)
treedd268ad252cce7f12dd5d443d576e28c92ba9afe /sysutils
parent792a309197ca3e7bb69875aaa0a423d5b1fc2b8f (diff)
- Use USE_PKGCONFIG macro
- Add patch when NLS is unset - Remove USE_AUTOTOOLS (libtool) macro Submitted by: myself Approved by: miwi, rene (mentors)
Notes
Notes: svn path=/head/; revision=302352
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/garcon/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/sysutils/garcon/Makefile b/sysutils/garcon/Makefile
index 035566b4567c..b150081ad33d 100644
--- a/sysutils/garcon/Makefile
+++ b/sysutils/garcon/Makefile
@@ -7,6 +7,7 @@
PORTNAME= garcon
PORTVERSION= 0.2.0
+PORTREVISION= 1
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DIST_SUBDIR= xfce4
@@ -14,12 +15,12 @@ DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Xfce 4 essential utilities and scripts
-USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 intltool intlhack pkgconfig
+USE_GNOME= gnomehack glib20 intltool intlhack
USE_XFCE= configenv libutil
+USE_PKGCONFIG= build
CONFIGURE_ARGS+=--disable-gtk-doc-html
@@ -44,4 +45,9 @@ CONFIGURE_ARGS+=--without-html-dir
PLIST_SUB+= APIDOCS="@comment "
.endif
+.if empty(PORT_OPTIONS:MNLS)
+post-patch:
+ @${REINPLACE_CMD} -e 's| po||' ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>