aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2016-06-05 16:59:53 +0000
committerRomain Tartière <romain@FreeBSD.org>2016-06-05 16:59:53 +0000
commit58296c9a70891d3efe84e7f478504de9ff66ad76 (patch)
tree6e57b6b904b3cab6184717af2abf177eed977c31 /sysutils
parent38614e2e92a720f7ac8f8eb0620e82b5f8af3e2c (diff)
downloadports-58296c9a70891d3efe84e7f478504de9ff66ad76.tar.gz
ports-58296c9a70891d3efe84e7f478504de9ff66ad76.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/mcollective-nrpe-agent/Makefile41
-rw-r--r--sysutils/mcollective-nrpe-agent/distinfo2
-rw-r--r--sysutils/mcollective-nrpe-agent/pkg-descr3
-rw-r--r--sysutils/mcollective-nrpe-client/Makefile19
-rw-r--r--sysutils/mcollective-nrpe-common/Makefile30
-rw-r--r--sysutils/mcollective-nrpe-common/distinfo2
-rw-r--r--sysutils/mcollective-nrpe-common/pkg-descr4
8 files changed, 65 insertions, 38 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index f01792c8c0c1..6d8332a9c068 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -554,6 +554,8 @@
SUBDIR += mcollective-nettest-client
SUBDIR += mcollective-nettest-common
SUBDIR += mcollective-nrpe-agent
+ SUBDIR += mcollective-nrpe-client
+ SUBDIR += mcollective-nrpe-common
SUBDIR += mcollective-puppet-agent
SUBDIR += mcollective-puppet-client
SUBDIR += mcollective-puppet-common
diff --git a/sysutils/mcollective-nrpe-agent/Makefile b/sysutils/mcollective-nrpe-agent/Makefile
index 168f8f69ba64..873d484a743e 100644
--- a/sysutils/mcollective-nrpe-agent/Makefile
+++ b/sysutils/mcollective-nrpe-agent/Makefile
@@ -1,44 +1,19 @@
# $FreeBSD$
PORTNAME= mcollective-nrpe-agent
-PORTVERSION= 20130805
-CATEGORIES= sysutils
+PORTEPOCH= 1
-MAINTAINER= ports@FreeBSD.org
-COMMENT= MCollective NRPE agent plugin
+COMMENT= MCollective agent to interact with the NRPE monitoring system
-RUN_DEPENDS= mcollective>=2:sysutils/mcollective
+# See MASTERDIR for MAINTAINER.
-USE_GITHUB= yes
-GH_ACCOUNT= puppetlabs
-GH_TAGNAME= ee29242
+RUN_DEPENDS= mcollective-nrpe-common>=${PORTVERSION}:${PORTSDIR}/sysutils/mcollective-nrpe-common
-PLIST_FILES= share/mcollective/agent/nrpe.ddl \
- share/mcollective/agent/nrpe.rb \
- share/mcollective/aggregate/nagios_states.rb \
- share/mcollective/application/nrpe.rb \
- share/mcollective/data/nrpe_data.ddl \
- share/mcollective/data/nrpe_data.rb \
- sbin/check-mc-nrpe
-PLIST_DIRS= share/mcollective/agent \
- share/mcollective/aggregate \
- share/mcollective/application \
- share/mcollective/data
+MASTERDIR= ${.CURDIR}/../mcollective-nrpe-common
-NO_BUILD= yes
+PLIST_FILES= share/mcollective/agent/nrpe.rb
do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "agent/*.rb" ${STAGEDIR}${PREFIX}/share/mcollective
-.for dir in ${PLIST_DIRS}
- ${MKDIR} ${STAGEDIR}${PREFIX}/${dir}
-.endfor
-
- ${INSTALL_DATA} ${WRKSRC}/agent/nrpe.ddl ${STAGEDIR}${PREFIX}/share/mcollective/agent/
- ${INSTALL_DATA} ${WRKSRC}/agent/nrpe.rb ${STAGEDIR}${PREFIX}/share/mcollective/agent/
- ${INSTALL_DATA} ${WRKSRC}/aggregate/nagios_states.rb ${STAGEDIR}${PREFIX}/share/mcollective/aggregate/
- ${INSTALL_DATA} ${WRKSRC}/application/nrpe.rb ${STAGEDIR}${PREFIX}/share/mcollective/application/
- ${INSTALL_DATA} ${WRKSRC}/data/nrpe_data.ddl ${STAGEDIR}${PREFIX}/share/mcollective/data/
- ${INSTALL_DATA} ${WRKSRC}/data/nrpe_data.rb ${STAGEDIR}${PREFIX}/share/mcollective/data/
- ${INSTALL_SCRIPT} ${WRKSRC}/sbin/check-mc-nrpe ${STAGEDIR}${PREFIX}/sbin/
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/mcollective-nrpe-agent/distinfo b/sysutils/mcollective-nrpe-agent/distinfo
deleted file mode 100644
index 3cf5c2f25bfb..000000000000
--- a/sysutils/mcollective-nrpe-agent/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (puppetlabs-mcollective-nrpe-agent-20130805-ee29242_GH0.tar.gz) = 7a145292dc7eae9915ea1c434951f7f75d042780c91983e2b1eb862e75d853e5
-SIZE (puppetlabs-mcollective-nrpe-agent-20130805-ee29242_GH0.tar.gz) = 8642
diff --git a/sysutils/mcollective-nrpe-agent/pkg-descr b/sysutils/mcollective-nrpe-agent/pkg-descr
deleted file mode 100644
index c29e2c47f307..000000000000
--- a/sysutils/mcollective-nrpe-agent/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-A MCollective NRPE Agent plugin with NRPE Data plugin included
-
-WWW: https://github.com/puppetlabs/mcollective-nrpe-agent
diff --git a/sysutils/mcollective-nrpe-client/Makefile b/sysutils/mcollective-nrpe-client/Makefile
new file mode 100644
index 000000000000..6adf1b5c8c37
--- /dev/null
+++ b/sysutils/mcollective-nrpe-client/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= mcollective-nrpe-client
+
+COMMENT= MCollective client to interact with the NRPE monitoring system
+
+# See MASTERDIR for MAINTAINER.
+
+RUN_DEPENDS= mcollective-nrpe-common>=${PORTVERSION}:${PORTSDIR}/sysutils/mcollective-nrpe-common
+
+MASTERDIR= ${.CURDIR}/../mcollective-nrpe-common
+
+PLIST_FILES= share/mcollective/aggregate/nagios_states.rb \
+ share/mcollective/application/nrpe.rb
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "aggregate/*.rb application/*.rb" ${STAGEDIR}${PREFIX}/share/mcollective
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/mcollective-nrpe-common/Makefile b/sysutils/mcollective-nrpe-common/Makefile
new file mode 100644
index 000000000000..ef106b317e0a
--- /dev/null
+++ b/sysutils/mcollective-nrpe-common/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME?= mcollective-nrpe-common
+PORTVERSION= 3.1.0
+CATEGORIES= sysutils
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT?= MCollective common files to interact with the NRPE monitoring system
+
+LICENSE= APACHE20
+
+RUN_DEPENDS?= mcollective>=2:${PORTSDIR}/sysutils/mcollective
+
+USE_GITHUB= yes
+GH_ACCOUNT= puppetlabs
+GH_PROJECT= mcollective-nrpe-agent
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES?= share/mcollective/agent/nrpe.ddl \
+ share/mcollective/data/nrpe_data.ddl \
+ share/mcollective/data/nrpe_data.rb
+
+.if !target(do-install)
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "agent/*.ddl data" ${STAGEDIR}${PREFIX}/share/mcollective
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/mcollective-nrpe-common/distinfo b/sysutils/mcollective-nrpe-common/distinfo
new file mode 100644
index 000000000000..11f46570d5b1
--- /dev/null
+++ b/sysutils/mcollective-nrpe-common/distinfo
@@ -0,0 +1,2 @@
+SHA256 (puppetlabs-mcollective-nrpe-agent-3.1.0_GH0.tar.gz) = 7e3f3956af091a5041f0e87501433c6a42471d6a2a9c30fa19f7481a3107c6db
+SIZE (puppetlabs-mcollective-nrpe-agent-3.1.0_GH0.tar.gz) = 12134
diff --git a/sysutils/mcollective-nrpe-common/pkg-descr b/sysutils/mcollective-nrpe-common/pkg-descr
new file mode 100644
index 000000000000..deecbb915590
--- /dev/null
+++ b/sysutils/mcollective-nrpe-common/pkg-descr
@@ -0,0 +1,4 @@
+The mcollective package agent lets you install, uninstall, update, purge and
+query the status of packages via MCollective.
+
+WWW: https://github.com/puppetlabs/mcollective-package-agent