aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-24 20:24:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-24 20:24:12 +0000
commit5ce23cd9176fa1c5037b22db0f2d9e359568016a (patch)
treee62b5c07a27e15895c35a8d9491258ab28e7aa41 /sysutils
parent3da1ad54b0ae97610202c7add6ea4be4df24b047 (diff)
downloadports-5ce23cd9176fa1c5037b22db0f2d9e359568016a.tar.gz
ports-5ce23cd9176fa1c5037b22db0f2d9e359568016a.zip
sysutils/conan: Fix build with py-urllib3 1.26.5
- While I'm here, update version requirement of RUN_DEPENDS
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/conan/Makefile2
-rw-r--r--sysutils/conan/files/patch-conans_requirements.txt12
2 files changed, 10 insertions, 4 deletions
diff --git a/sysutils/conan/Makefile b/sysutils/conan/Makefile
index 43d3f7ed9ba7..077fcc435675 100644
--- a/sysutils/conan/Makefile
+++ b/sysutils/conan/Makefile
@@ -26,7 +26,7 @@ PY_DEPENDS= \
${PYTHON_PKGNAMEPREFIX}requests>=2.8.1,<3.0.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}urllib3>=1.25.8:net/py-urllib3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=1.25.8,1<1.27,1:net/py-urllib3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tqdm>=4.28.1:misc/py-tqdm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml@${PY_FLAVOR}
BUILD_DEPENDS= ${PY_DEPENDS}
diff --git a/sysutils/conan/files/patch-conans_requirements.txt b/sysutils/conan/files/patch-conans_requirements.txt
index 4e69a0aff7c7..6f66d84d9cfa 100644
--- a/sysutils/conan/files/patch-conans_requirements.txt
+++ b/sysutils/conan/files/patch-conans_requirements.txt
@@ -1,6 +1,12 @@
---- conans/requirements.txt.orig 2020-09-02 09:40:01 UTC
+--- conans/requirements.txt.orig 2021-06-30 14:03:08 UTC
+++ conans/requirements.txt
-@@ -6,11 +6,11 @@ PyYAML>=3.11, <6.0
+@@ -1,16 +1,16 @@
+ PyJWT>=1.4.0, <2.0.0
+ requests>=2.8.1, <3.0.0
+-urllib3>=1.25.8, <1.26
++urllib3>=1.25.8, <1.27
+ colorama>=0.3.3, <0.5.0
+ PyYAML>=3.11, <6.0
patch-ng>=1.17.4, <1.18
fasteners>=0.14.1
six>=1.10.0,<=1.15.0
@@ -13,5 +19,5 @@
-deprecation>=2.0, <2.1
+deprecation>=2.0
tqdm>=4.28.1, <5
- Jinja2>=2.3, <3
+ Jinja2>=2.9, <3
python-dateutil>=2.7.0, <3