aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorBrian Somers <brian@FreeBSD.org>2001-07-03 15:45:54 +0000
committerBrian Somers <brian@FreeBSD.org>2001-07-03 15:45:54 +0000
commit650e3176f53651f44ec8497b81831b79eecc2e50 (patch)
tree6e04f55f0a00c946a76d610043bea01233973e8b /sysutils
parentcd3cb2536e30ae77ba8003af6d1a4240f9445a65 (diff)
downloadports-650e3176f53651f44ec8497b81831b79eecc2e50.tar.gz
ports-650e3176f53651f44ec8497b81831b79eecc2e50.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/dvdtape/Makefile2
-rw-r--r--sysutils/dvdtape/distinfo2
-rw-r--r--sysutils/dvdtape/files/patch-ab9
-rw-r--r--sysutils/dvdtape/files/patch-ac77
4 files changed, 8 insertions, 82 deletions
diff --git a/sysutils/dvdtape/Makefile b/sysutils/dvdtape/Makefile
index 48c11d258dc6..255529c20a86 100644
--- a/sysutils/dvdtape/Makefile
+++ b/sysutils/dvdtape/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dvdtape
-PORTVERSION= 1.4
+PORTVERSION= 1.5
PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.Awfulhak.org/pub/dvdtape/ \
diff --git a/sysutils/dvdtape/distinfo b/sysutils/dvdtape/distinfo
index 1265734318a0..000a562b68e7 100644
--- a/sysutils/dvdtape/distinfo
+++ b/sysutils/dvdtape/distinfo
@@ -1 +1 @@
-MD5 (dvdtape-1.4.tar.gz) = 3d8a64432a2e40715b35179a7011866e
+MD5 (dvdtape-1.5.tar.gz) = a9b3f415ddd8910b9a0ce2f2fe546dd1
diff --git a/sysutils/dvdtape/files/patch-ab b/sysutils/dvdtape/files/patch-ab
index 8c6c475859e5..8f8367b9cbeb 100644
--- a/sysutils/dvdtape/files/patch-ab
+++ b/sysutils/dvdtape/files/patch-ab
@@ -1,10 +1,13 @@
--- isosize.c.orig Wed Nov 10 00:11:39 1999
-+++ isosize.c Tue Apr 3 19:10:32 2001
-@@ -1,6 +1,6 @@
++++ isosize.c Tue Jul 3 16:38:21 2001
+@@ -1,6 +1,10 @@
#define _POSIX_SOURCE 1 /* fileno is POSIX, not ANSI */
#include <stdio.h>
--#include <termio.h>
++#ifdef __FreeBSD__
+#include <termios.h>
++#else
+ #include <termio.h>
++#endif
#include <signal.h>
#include <unistd.h>
diff --git a/sysutils/dvdtape/files/patch-ac b/sysutils/dvdtape/files/patch-ac
deleted file mode 100644
index a2eedd451619..000000000000
--- a/sysutils/dvdtape/files/patch-ac
+++ /dev/null
@@ -1,77 +0,0 @@
---- dvdtape.c.orig Wed Aug 2 08:58:21 2000
-+++ dvdtape.c Sun Jun 10 22:27:29 2001
-@@ -153,8 +153,8 @@
- fprintf (stderr,
- "Disc diameter must be \"8cm\" or \"12cm\".\n");
- exit(1);
-- break;
- }
-+ break;
- case 'l': layer = atoi(optarg); break;
- case 'L':
- layers = atoi(optarg);
-@@ -184,6 +184,7 @@
- "Read out speed must be 2, 5 or 10 for 2.52, 5.04, or 10.08 megabits/second.\n");
- exit(1);
- }
-+ break;
- case 's': side = atoi(optarg); break;
- case 'S':
- sides = atoi(optarg);
-@@ -335,7 +336,7 @@
- static void
- write_vol_label(int outfd) {
- char buf[81];
-- sprintf(buf,
-+ snprintf(buf, sizeof(buf),
- "VOL1" /* Label ID */
- "REEL%-2d" /* Reel ID */
- " " /* Accessibility */
-@@ -351,7 +352,7 @@
- static void
- write_hdr1(int outfd, char *labelid, char *fileid, int block_count) {
- char buf[81];
-- sprintf(buf,
-+ snprintf(buf, sizeof(buf),
- "%-4s" /* Label ID */
- "%-17s" /* File ID */
- "DVD " /* File set ID, 6 bytes */
-@@ -394,7 +395,7 @@
- static void
- write_hdr2(int outfd, char *labelid, int blocksize, int recordsize) {
- char buf[81];
-- sprintf(buf,
-+ snprintf(buf, sizeof(buf),
- "%-4s" /* Label ID */
- "F" /* Record format, "F" = fixed */
- "%05d" /* block size */
-@@ -415,9 +416,9 @@
- if (strlen(usertext) == 0)
- strcpy(txtsize, " ");
- else
-- sprintf (txtsize, "%02d", strlen(usertext));
-+ snprintf (txtsize, sizeof(txtsize), "%02d", strlen(usertext));
-
-- sprintf(buf,
-+ snprintf(buf, sizeof(buf),
- "DDP 2.00" /* DDP level */
- " " /* UPC, reserved, 13 bytes */
- " " /* MSS, Map Stream Start, 8 bytes */
-@@ -456,7 +457,7 @@
- static void
- write_ddpms(int outfd, char *streamtype, int start, int len, char *filename) {
- char buf[129];
-- sprintf(buf,
-+ snprintf(buf, sizeof(buf),
- "VVVM" /* MPV Map Packet Valid */
- "%-2s" /* DST Data Stream Type
- "D2" = control
-@@ -657,7 +658,7 @@
- struct tm *tm;
- time(&now);
- tm = localtime(&now);
-- sprintf (time_string, "%c%02d%03d",
-+ snprintf (time_string, sizeof(time_string), "%c%02d%03d",
- tm->tm_year >= 100 ? '0' : ' ',
- tm->tm_year % 100,
- tm->tm_yday + 1 /* E.g., Write Jan 1 as day 1, not day 0.*/