aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-26 09:00:53 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-26 09:00:53 +0000
commit6abbdf7eb80a1983c5ffd5f211d1245df7af7171 (patch)
tree3787e78169a2e4f033ae47d6680a1310bcd85d81 /sysutils
parenta5ec31870c0e3ab051c5161c993e3ae34d03303f (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/915resolution/Makefile11
-rw-r--r--sysutils/915resolution/files/patch-915resolution.c16
2 files changed, 16 insertions, 11 deletions
diff --git a/sysutils/915resolution/Makefile b/sysutils/915resolution/Makefile
index 7c3fc6b68b93..65aa3c990933 100644
--- a/sysutils/915resolution/Makefile
+++ b/sysutils/915resolution/Makefile
@@ -11,20 +11,25 @@ MASTER_SITES= LOCAL/cy
MAINTAINER= ports@FreeBSD.org
COMMENT= Resolution tool for Intel i915 video cards
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+ONLY_FOR_ARCHS= i386 amd64
+
USE_RC_SUBR= 915resolution
PLIST_FILES= sbin/915resolution
-PORTDOCS= README.txt LICENSE.txt chipset_info.txt changes.log
+PORTDOCS= README.txt chipset_info.txt changes.log
OPTIONS_DEFINE= DOCS
-ONLY_FOR_ARCHS= i386 amd64
-
do-build:
${CC} ${CFLAGS} ${WRKSRC}/915resolution.c -o ${WRKSRC}/915resolution
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/915resolution ${STAGEDIR}${PREFIX}/sbin
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/sysutils/915resolution/files/patch-915resolution.c b/sysutils/915resolution/files/patch-915resolution.c
index 35adaa38ba01..a942079d7267 100644
--- a/sysutils/915resolution/files/patch-915resolution.c
+++ b/sysutils/915resolution/files/patch-915resolution.c
@@ -1,5 +1,5 @@
---- 915resolution.c.orig Sun Apr 15 06:46:56 2007
-+++ 915resolution.c Sun Apr 15 06:46:56 2007
+--- 915resolution.c.orig 2007-04-15 10:46:56 UTC
++++ 915resolution.c
@@ -21,8 +21,10 @@
#define __USE_GNU
#include <string.h>
@@ -12,7 +12,7 @@
#include <unistd.h>
#include <assert.h>
-@@ -165,7 +167,8 @@
+@@ -165,7 +167,8 @@ typedef struct {
void initialize_system(char * filename) {
if (!filename) {
@@ -22,7 +22,7 @@
perror("Unable to obtain the proper IO permissions");
exit(2);
}
-@@ -173,7 +176,7 @@
+@@ -173,7 +176,7 @@ void initialize_system(char * filename)
}
cardinal get_chipset_id(void) {
@@ -31,7 +31,7 @@
return inl(0xcfc);
}
-@@ -496,11 +499,11 @@
+@@ -496,11 +499,11 @@ void unlock_vbios(vbios_map * map) {
break;
case CT_830:
case CT_855GM:
@@ -46,7 +46,7 @@
break;
case CT_845G:
case CT_865G:
-@@ -511,13 +514,13 @@
+@@ -511,13 +514,13 @@ void unlock_vbios(vbios_map * map) {
case CT_946GZ:
case CT_G965:
case CT_Q965:
@@ -64,7 +64,7 @@
break;
}
-@@ -539,8 +542,8 @@
+@@ -539,8 +542,8 @@ void relock_vbios(vbios_map * map) {
break;
case CT_830:
case CT_855GM:
@@ -75,7 +75,7 @@
break;
case CT_845G:
case CT_865G:
-@@ -551,9 +554,9 @@
+@@ -551,9 +554,9 @@ void relock_vbios(vbios_map * map) {
case CT_946GZ:
case CT_G965:
case CT_Q965: