aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-07-03 23:40:27 +0000
committerSteve Price <steve@FreeBSD.org>1998-07-03 23:40:27 +0000
commit74d96100ede3a93bd4c9fe074ad76092fda0c2a2 (patch)
treef927e3015b10b3de7c01d2adc66010bf1ca56faf /sysutils
parent4c338b08a1019d82f47ffa307bd423e8329e2fa7 (diff)
downloadports-74d96100ede3a93bd4c9fe074ad76092fda0c2a2.tar.gz
ports-74d96100ede3a93bd4c9fe074ad76092fda0c2a2.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/upsd/Makefile6
-rw-r--r--sysutils/upsd/files/patch-ab2
-rw-r--r--sysutils/upsd/files/patch-ac9
3 files changed, 13 insertions, 4 deletions
diff --git a/sysutils/upsd/Makefile b/sysutils/upsd/Makefile
index 706ce89242a9..335be5333b4a 100644
--- a/sysutils/upsd/Makefile
+++ b/sysutils/upsd/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 Jul 1996
# Whom: alexis
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/02/25 16:46:22 steve Exp $
#
DISTNAME= upsd-2.0.1.6
@@ -18,8 +18,8 @@ MAINTAINER= alexis@ww.net
WRKSRC= ${WRKDIR}/upsd-2.0
pre-build:
- @${MV} ${WRKSRC}/config.h ${WRKSRC}/config.h.orig
- @sed -e "s!@prefix@!${PREFIX}!g" ${WRKSRC}/config.h.orig > ${WRKSRC}/config.h
+ @${MV} ${WRKSRC}/config.h ${WRKSRC}/conf.h.orig
+ @sed -e "s!@prefix@!${PREFIX}!g" ${WRKSRC}/conf.h.orig > ${WRKSRC}/conf.h
post-install:
if [ ! -f ${PREFIX}/etc/upsd.conf ] ; then \
diff --git a/sysutils/upsd/files/patch-ab b/sysutils/upsd/files/patch-ab
index 4a42c0055377..c86395b570f5 100644
--- a/sysutils/upsd/files/patch-ab
+++ b/sysutils/upsd/files/patch-ab
@@ -5,7 +5,7 @@
#ifndef DEBUG
-#define _PATH_UPSD_CONF "/etc/upsd.conf"
-+#define _PATH_UPSD_CONF "@prefix@/upsd.conf"
++#define _PATH_UPSD_CONF "@prefix@/etc/upsd.conf"
#define _PATH_UPSD_PID "/var/run/upsd.pid"
#else
#define _PATH_UPSD_CONF "sample/upsd.conf"
diff --git a/sysutils/upsd/files/patch-ac b/sysutils/upsd/files/patch-ac
new file mode 100644
index 000000000000..1b1899a6a957
--- /dev/null
+++ b/sysutils/upsd/files/patch-ac
@@ -0,0 +1,9 @@
+--- upsd.h.orig Fri Jul 3 13:52:01 1998
++++ upsd.h Fri Jul 3 13:52:21 1998
+@@ -206,5 +206,5 @@
+
+ #define TERMINATE kill(getpid(), SIGTERM)
+
+-#include "config.h"
++#include "conf.h"
+ #include "proto.h"