aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-04-07 03:04:52 +0000
committerWen Heping <wen@FreeBSD.org>2010-04-07 03:04:52 +0000
commit79c81dcba653660cfb511f4d1c1b8728f7238961 (patch)
treeffbac01d28d37dbd7574881b02c868b1af90bb6c /sysutils
parent635b901ad647a80446cdf844c796799e2ebfae9a (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/moosefs-client/Makefile44
-rw-r--r--sysutils/moosefs-client/distinfo3
-rw-r--r--sysutils/moosefs-client/pkg-descr8
-rw-r--r--sysutils/moosefs-client/pkg-plist20
5 files changed, 76 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 27e77802161d..f35b51c5f02f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -496,6 +496,7 @@
SUBDIR += monkeytail
SUBDIR += mono-kmod
SUBDIR += moosefs-chunkserver
+ SUBDIR += moosefs-client
SUBDIR += moosefs-master
SUBDIR += moreutils
SUBDIR += most
diff --git a/sysutils/moosefs-client/Makefile b/sysutils/moosefs-client/Makefile
new file mode 100644
index 000000000000..446ca3a59c17
--- /dev/null
+++ b/sysutils/moosefs-client/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: moosefs-client
+# Date created: 1 April 2010
+# Whom: Chifeng Qu <chifeng@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moosefs
+PORTVERSION= 1.6.14
+CATEGORIES= sysutils
+MASTER_SITES= SF/moosefs/moosefs/${PORTVERSION}/
+PKGNAMESUFFIX= -client
+DISTNAME= mfs-${PORTVERSION}
+
+MAINTAINER= chifeng@gmail.com
+COMMENT= Moosefs client tools
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/pkg-config:${PORTSDIR}/devel/pkg-config \
+ ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+GNU_CONFIGURE= yes
+
+MAN1= mfstools.1 mfscheckfile.1 mfsdirinfo.1 mfsfileinfo.1 \
+ mfsfilerepair.1 mfsgetgoal.1 mfsgettrashtime.1 \
+ mfsrgetgoal.1 mfsrgettrashtime.1 mfsrsetgoal.1 \
+ mfsrsettrashtime.1 mfssetgoal.1 mfssettrashtime.1 \
+ mfsgeteattr.1 mfsseteattr.1 mfsdeleattr.1 \
+ mfsappendchunks.1 mfsmakesnapshot.1
+MAN8= mfsmount.8
+
+CONFIGURE_ARGS= --with-default-user=${MFSUSER} \
+ --with-default-group=${MFSGROUP} \
+ --disable-mfsmaster \
+ --disable-mfschunkserver \
+ --disable-mfscgi \
+ --disable-mfscgiserv \
+ --enable-mfsmount
+
+post-patch:
+ ${REINPLACE_CMD} -e 's;^general_mans;#general_mans;g' ${WRKSRC}/doc/Makefile.am \
+ ${WRKSRC}/doc/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/sysutils/moosefs-client/distinfo b/sysutils/moosefs-client/distinfo
new file mode 100644
index 000000000000..ba8b366a3794
--- /dev/null
+++ b/sysutils/moosefs-client/distinfo
@@ -0,0 +1,3 @@
+MD5 (mfs-1.6.14.tar.gz) = 746e742011f6ada5ec64152c4fd2ddbd
+SHA256 (mfs-1.6.14.tar.gz) = 8c29a71d391cb77e528459aced3f12bdbff813baed2a43461c3e1818f2492411
+SIZE (mfs-1.6.14.tar.gz) = 641406
diff --git a/sysutils/moosefs-client/pkg-descr b/sysutils/moosefs-client/pkg-descr
new file mode 100644
index 000000000000..bb6d95f5b551
--- /dev/null
+++ b/sysutils/moosefs-client/pkg-descr
@@ -0,0 +1,8 @@
+MooseFS is a fault tolerant, network distributed file system.
+
+moosefs client is any number of machines using mfsmount process
+to communicate with the managing server (to receive and modify
+file metadata) and with chunkservers (to exchange actual file
+data).
+
+WWW: http://www.moosefs.org/
diff --git a/sysutils/moosefs-client/pkg-plist b/sysutils/moosefs-client/pkg-plist
new file mode 100644
index 000000000000..ab2bb8672cba
--- /dev/null
+++ b/sysutils/moosefs-client/pkg-plist
@@ -0,0 +1,20 @@
+bin/mfsmakesnapshot
+bin/mfscheckfile
+bin/mfsdirinfo
+bin/mfsfileinfo
+bin/mfsfilerepair
+bin/mfsgetgoal
+bin/mfsgettrashtime
+bin/mfsrgetgoal
+bin/mfsrgettrashtime
+bin/mfsrsetgoal
+bin/mfsrsettrashtime
+bin/mfssetgoal
+bin/mfssettrashtime
+bin/mfsgeteattr
+bin/mfsseteattr
+bin/mfsdeleattr
+bin/mfsappendchunks
+bin/mfsmount
+bin/mfstools
+bin/mfssnapshot