aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-05-08 20:31:59 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-05-08 20:31:59 +0000
commit7da857cb1ae34a897e56b6b0eb3ef5ffc376e1c9 (patch)
tree1cd1b32d402e35bf5f46c8b2160d981150881e18 /sysutils
parentbfe24f17a12caedd33b4e45debaed8fcda101888 (diff)
downloadports-7da857cb1ae34a897e56b6b0eb3ef5ffc376e1c9.tar.gz
ports-7da857cb1ae34a897e56b6b0eb3ef5ffc376e1c9.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/jail2/Makefile2
-rw-r--r--sysutils/jail2/files/jail2.in6
2 files changed, 4 insertions, 4 deletions
diff --git a/sysutils/jail2/Makefile b/sysutils/jail2/Makefile
index 5f6429b10ad1..edb031dae079 100644
--- a/sysutils/jail2/Makefile
+++ b/sysutils/jail2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= jail2
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= sysutils
MASTER_SITES= #
DISTFILES= #
diff --git a/sysutils/jail2/files/jail2.in b/sysutils/jail2/files/jail2.in
index cda2e6fcad5c..3066f871dc0a 100644
--- a/sysutils/jail2/files/jail2.in
+++ b/sysutils/jail2/files/jail2.in
@@ -12,7 +12,7 @@
# To manage ZFS datasets within a jail the dataset must have
# set the parameter "jailed" to 1. Additionally the jail must
# have set the proberties "allow.mount", "allow.mount.zfs"
-# and "enforce_statfs" to value lesser than 2.
+# and "enforce_statfs" to 0.
# PROVIDE: jail
# REQUIRE: LOGIN cleanvar
@@ -31,6 +31,8 @@ jail2_start()
{
echo -n "Starting jails: "
+ devfs_init_rulesets
+
for _j in ${jail2_list}; do
echo -n "${_j} "
@@ -48,7 +50,6 @@ jail2_start()
for _ds in ${_zfs}; do
_jailed=`zfs get -H jailed ${_ds} 2>/dev/null | awk '{ print $3 }'`
if [ "${_jailed}" = "on" ]; then
- echo "zfs jail "${_jid}" ${_ds} 2>/dev/null"
zfs jail "${_jid}" ${_ds} 2>/dev/null
fi
done
@@ -80,7 +81,6 @@ jail2_stop()
for _ds in ${_zfs}; do
_jailed=`zfs get -H jailed ${_ds} 2>/dev/null | awk '{ print $3 }'`
if [ "${_jailed}" = "on" ]; then
- echo "zfs unjail "${_jid}" ${_ds} 2>/dev/null"
zfs unjail "${_jid}" ${_ds} 2>/dev/null
fi
done