aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-02-19 17:37:17 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-02-19 17:37:17 +0000
commit8ad7d8405eb44575b430f0e83b3d86f50840c1fc (patch)
tree575d8baa1bc7a5e38639ca85d25c12fd1c288351 /sysutils
parent97eb5b8abab396f39bc6cb8b4d990ff68f7fbfd7 (diff)
downloadports-8ad7d8405eb44575b430f0e83b3d86f50840c1fc.tar.gz
ports-8ad7d8405eb44575b430f0e83b3d86f50840c1fc.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-httpfs/Makefile31
-rw-r--r--sysutils/fusefs-httpfs/distinfo4
-rw-r--r--sysutils/fusefs-httpfs/files/patch-Makefile39
-rw-r--r--sysutils/fusefs-httpfs/files/patch-httpfs.c14
-rw-r--r--sysutils/fusefs-httpfs/files/patch-httpfs2.c38
5 files changed, 92 insertions, 34 deletions
diff --git a/sysutils/fusefs-httpfs/Makefile b/sysutils/fusefs-httpfs/Makefile
index 01ca1e3e2b79..8af25dcc97f7 100644
--- a/sysutils/fusefs-httpfs/Makefile
+++ b/sysutils/fusefs-httpfs/Makefile
@@ -1,32 +1,27 @@
-# New ports collection makefile for: fusefs-httpfs
-# Date created: 2006-07-16
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= httpfs
-PORTVERSION= 2.06.08.26
+PORTVERSION= 2.${VERSION}
CATEGORIES= sysutils www
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}_with_static_binaries_${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}2/
PKGNAMEPREFIX= fusefs-
-DISTNAME= ${PORTNAME}_with_static_binaries_${PORTVERSION}
+DISTNAME= ${PORTNAME}2-${VERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Fuse-based http filesystem
-USE_FUSE= yes
-PLIST_FILES= bin/httpfs
-WRKSRC= ${WRKDIR}
+WRKSRC= ${WRKDIR}/${PORTNAME}2-${VERSION}
-do-build:
- (cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include/fuse \
- -DUSE_AUTH -D_FILE_OFFSET_BITS=64 -D_REENTRANT \
- -DFUSE_USE_VERSION=25 -D_POSIX_C_SOURCE=200112L -D_POSIX_SOURCE \
- -D_SVID_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE=500 \
- -o httpfs httpfs.c -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lfuse)
+VERSION= 0.1.5
+USE_FUSE= yes
+USE_PKGCONFIG= yes
+USE_GMAKE= yes
+CFLAGS+= -D__BSD_VISIBLE
+ALL_TARGET= httpfs2
+PLIST_FILES= bin/httpfs2
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/httpfs ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/httpfs2 ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-httpfs/distinfo b/sysutils/fusefs-httpfs/distinfo
index 392fc41a9e85..edd611d2f23d 100644
--- a/sysutils/fusefs-httpfs/distinfo
+++ b/sysutils/fusefs-httpfs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (httpfs_with_static_binaries_2.06.08.26.tar.gz) = b34d23d9e67b3e7931b2c0dc53fd997dcaf3d6b2126f87a25b51dd00c25e4e65
-SIZE (httpfs_with_static_binaries_2.06.08.26.tar.gz) = 115384
+SHA256 (httpfs2-0.1.5.tar.gz) = 01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1
+SIZE (httpfs2-0.1.5.tar.gz) = 16870
diff --git a/sysutils/fusefs-httpfs/files/patch-Makefile b/sysutils/fusefs-httpfs/files/patch-Makefile
new file mode 100644
index 000000000000..f64302e6aa5d
--- /dev/null
+++ b/sysutils/fusefs-httpfs/files/patch-Makefile
@@ -0,0 +1,39 @@
+--- Makefile.orig 2012-09-03 16:58:02.000000000 +0200
++++ Makefile 2013-02-19 18:03:41.000000000 +0100
+@@ -1,5 +1,5 @@
+ MAIN_CFLAGS := -g -Os -Wall $(shell pkg-config fuse --cflags)
+-MAIN_CPPFLAGS := -Wall -Wno-unused-function -Wconversion -Wtype-limits -DUSE_AUTH -D_XOPEN_SOURCE=700 -D_ISOC99_SOURCE
++MAIN_CPPFLAGS := -Wall -Wno-unused-function -Wconversion -DUSE_AUTH -D_XOPEN_SOURCE=700 -D_ISOC99_SOURCE
+ THR_CPPFLAGS := -DUSE_THREAD
+ THR_LDFLAGS := -lpthread
+ MAIN_LDFLAGS := $(shell pkg-config fuse --libs | sed -e s/-lrt// -e s/-ldl// -e s/-pthread// -e "s/ / /g")
+@@ -45,7 +45,7 @@
+ $(MAKE) $* $(addprefix $*,$(variants))
+
+ %.1: %.1.txt
+- a2x -f manpage $<
++ a2x -L -f manpage $<
+
+ %-ssl: $*
+ $(MAKE) CPPFLAGS='$(CPPFLAGS) $(SSL_CPPFLAGS)' LDFLAGS='$(LDFLAGS) $(SSL_LDFLAGS)' binsuffix=-ssl$(binsuffix) $*
+@@ -61,20 +61,6 @@
+
+ # Rules to automatically make a Debian package
+
+-package = $(shell dpkg-parsechangelog | grep ^Source: | sed -e s,'^Source: ',,)
+-version = $(shell dpkg-parsechangelog | grep ^Version: | sed -e s,'^Version: ',, -e 's,-.*,,')
+-revision = $(shell dpkg-parsechangelog | grep ^Version: | sed -e -e 's,.*-,,')
+-architecture = $(shell dpkg --print-architecture)
+-tar_dir = $(package)-$(version)
+-tar_gz = $(tar_dir).tar.gz
+-pkg_deb_dir = pkgdeb
+-unpack_dir = $(pkg_deb_dir)/$(tar_dir)
+-orig_tar_gz = $(pkg_deb_dir)/$(package)_$(version).orig.tar.gz
+-pkg_deb_src = $(pkg_deb_dir)/$(package)_$(version)-$(revision)_source.changes
+-pkg_deb_bin = $(pkg_deb_dir)/$(package)_$(version)-$(revision)_$(architecture).changes
+-
+-deb_pkg_key = CB8C5858
+-
+ debclean:
+ rm -rf $(pkg_deb_dir)
+
diff --git a/sysutils/fusefs-httpfs/files/patch-httpfs.c b/sysutils/fusefs-httpfs/files/patch-httpfs.c
deleted file mode 100644
index 6cac4cbb3088..000000000000
--- a/sysutils/fusefs-httpfs/files/patch-httpfs.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- httpfs.c.orig Sun Jul 16 22:48:19 2006
-+++ httpfs.c Sun Jul 16 22:48:39 2006
-@@ -32,9 +32,10 @@
- #include <errno.h>
- #include <fcntl.h>
- #include <sys/stat.h>
--#include <sys/dir.h>
-+#include <dirent.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <sys/select.h>
- #include <netinet/in.h>
- #include <netdb.h>
- #include <time.h>
diff --git a/sysutils/fusefs-httpfs/files/patch-httpfs2.c b/sysutils/fusefs-httpfs/files/patch-httpfs2.c
new file mode 100644
index 000000000000..512f4eb6d4e7
--- /dev/null
+++ b/sysutils/fusefs-httpfs/files/patch-httpfs2.c
@@ -0,0 +1,38 @@
+--- httpfs2.c.orig 2013-02-19 15:45:06.000000000 +0100
++++ httpfs2.c 2013-02-19 15:48:43.000000000 +0100
+@@ -35,7 +35,7 @@
+ #include <assert.h>
+ #include <ctype.h>
+ #include <sys/stat.h>
+-#include <sys/dir.h>
++#include <dirent.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <sys/socket.h>
+@@ -188,7 +188,7 @@
+
+ static int httpfs_stat(fuse_ino_t ino, struct stat *stbuf)
+ {
+- stbuf->st_ino = ino;
++ stbuf->st_ino = (uint32_t)ino;
+ switch (ino) {
+ case 1:
+ stbuf->st_mode = S_IFDIR | 0755;
+@@ -257,7 +257,7 @@
+ b->size += fuse_add_direntry(req, NULL, 0, name, NULL, 0);
+ b->p = (char *) realloc(b->p, b->size);
+ memset(&stbuf, 0, sizeof(stbuf));
+- stbuf.st_ino = ino;
++ stbuf.st_ino = (uint32_t)ino;
+ fuse_add_direntry(req, b->p + oldsize, b->size - oldsize, name, &stbuf,
+ (off_t) b->size);
+ }
+@@ -667,7 +667,7 @@
+
+ static int init_url(struct_url* url)
+ {
+- memset(url, 0, sizeof(url));
++ memset(url, 0, sizeof(*url));
+ url->sock_type = SOCK_CLOSED;
+ url->timeout = TIMEOUT;
+ #ifdef USE_SSL