aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2015-01-08 14:41:53 +0000
committerKris Moore <kmoore@FreeBSD.org>2015-01-08 14:41:53 +0000
commit8f2547d649fff3a05f3e2c46a709bb20df713e45 (patch)
treeeb46a92f33dbd88365778c0eeef1b5b40b6af8b1 /sysutils
parent48819b0d3e29f6bd994a5a5011c037c2d1c5b597 (diff)
downloadports-8f2547d649fff3a05f3e2c46a709bb20df713e45.tar.gz
ports-8f2547d649fff3a05f3e2c46a709bb20df713e45.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/grub2-efi/Makefile2
-rw-r--r--sysutils/grub2-efi/files/patch-grub-core_loader_i386_bsd.c20
-rw-r--r--sysutils/grub2-pcbsd/Makefile2
-rw-r--r--sysutils/grub2-pcbsd/files/patch-grub-core_loader_i386_bsd.c20
4 files changed, 42 insertions, 2 deletions
diff --git a/sysutils/grub2-efi/Makefile b/sysutils/grub2-efi/Makefile
index b406d414a883..715fdf9f26c0 100644
--- a/sysutils/grub2-efi/Makefile
+++ b/sysutils/grub2-efi/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grub2-efi
PORTVERSION= 2.02
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= sysutils
MASTER_SITES= http://www.pcbsd.org/~kris/software/ \
ftp://ftp.pcbsd.org/pub/software/
diff --git a/sysutils/grub2-efi/files/patch-grub-core_loader_i386_bsd.c b/sysutils/grub2-efi/files/patch-grub-core_loader_i386_bsd.c
new file mode 100644
index 000000000000..2f1db76fb002
--- /dev/null
+++ b/sysutils/grub2-efi/files/patch-grub-core_loader_i386_bsd.c
@@ -0,0 +1,20 @@
+diff --git grub-core/loader/i386/bsd.c grub-core/loader/i386/bsd.c
+index 8f691e0..8c7decd 100644
+--- grub-core/loader/i386/bsd.c
++++ grub-core/loader/i386/bsd.c
+@@ -415,11 +415,14 @@ grub_freebsd_add_meta_module (const char *filename, const char *type,
+ grub_addr_t addr, grub_uint32_t size)
+ {
+ const char *name;
+- name = grub_strrchr (filename, '/');
++ /* Don't strip the full path, some FreeBSD functionality, such
++ * as dtrace, rely on this. Instead only strip out the portion after ZFS @ sign */
++ name = grub_strrchr (filename, '@');
+ if (name)
+ name++;
+ else
+ name = filename;
++
+ if (grub_strcmp (type, "/boot/zfs/zpool.cache") == 0)
+ name = "/boot/zfs/zpool.cache";
+
diff --git a/sysutils/grub2-pcbsd/Makefile b/sysutils/grub2-pcbsd/Makefile
index 30d038fa3d32..1028449b1b58 100644
--- a/sysutils/grub2-pcbsd/Makefile
+++ b/sysutils/grub2-pcbsd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grub2-pcbsd
PORTVERSION= 2.02p
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= sysutils
MASTER_SITES= http://www.pcbsd.org/~kris/software/ \
ftp://ftp.pcbsd.org/pub/software/
diff --git a/sysutils/grub2-pcbsd/files/patch-grub-core_loader_i386_bsd.c b/sysutils/grub2-pcbsd/files/patch-grub-core_loader_i386_bsd.c
new file mode 100644
index 000000000000..2f1db76fb002
--- /dev/null
+++ b/sysutils/grub2-pcbsd/files/patch-grub-core_loader_i386_bsd.c
@@ -0,0 +1,20 @@
+diff --git grub-core/loader/i386/bsd.c grub-core/loader/i386/bsd.c
+index 8f691e0..8c7decd 100644
+--- grub-core/loader/i386/bsd.c
++++ grub-core/loader/i386/bsd.c
+@@ -415,11 +415,14 @@ grub_freebsd_add_meta_module (const char *filename, const char *type,
+ grub_addr_t addr, grub_uint32_t size)
+ {
+ const char *name;
+- name = grub_strrchr (filename, '/');
++ /* Don't strip the full path, some FreeBSD functionality, such
++ * as dtrace, rely on this. Instead only strip out the portion after ZFS @ sign */
++ name = grub_strrchr (filename, '@');
+ if (name)
+ name++;
+ else
+ name = filename;
++
+ if (grub_strcmp (type, "/boot/zfs/zpool.cache") == 0)
+ name = "/boot/zfs/zpool.cache";
+