aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2020-02-17 04:40:23 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2020-02-17 04:40:23 +0000
commitaebb66b47599ce3ce20964336a4c523d6bf8021d (patch)
tree74e9f234d6d096482447812af92e72bffe91e51e /sysutils
parentfd869679891863fe55dc692e4083361aaf77f0cd (diff)
downloadports-aebb66b47599ce3ce20964336a4c523d6bf8021d.tar.gz
ports-aebb66b47599ce3ce20964336a4c523d6bf8021d.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/iichid/Makefile39
-rw-r--r--sysutils/iichid/distinfo3
-rw-r--r--sysutils/iichid/pkg-descr7
-rw-r--r--sysutils/iichid/pkg-message5
5 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ed595dda8c51..79803e70d138 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -491,6 +491,7 @@
SUBDIR += i2c-tools
SUBDIR += i7z
SUBDIR += iat
+ SUBDIR += iichid
SUBDIR += immortal
SUBDIR += incron
SUBDIR += inotify-tools
diff --git a/sysutils/iichid/Makefile b/sysutils/iichid/Makefile
new file mode 100644
index 000000000000..1d33dead9715
--- /dev/null
+++ b/sysutils/iichid/Makefile
@@ -0,0 +1,39 @@
+# Created by: jrhett@netconsonance.com
+# $FreeBSD$
+
+PORTNAME= iichid
+DISTVERSION= 0.0.1
+CATEGORIES= sysutils
+
+MAINTAINER= imp@FreeBSD.org
+COMMENT= Generic FreeBSD HID layer for I2C and USB devices
+
+LICENSE= BSD2CLAUSE
+#LICENSE_FILE= Not yet packaged
+
+ONLY_FOR_ARCHS= aarch64 amd64 i386
+ONLY_FOR_ARCHS_REASON= Requires architecture supporting ACPI
+
+USES= kmod uidfix
+
+USE_GITHUB= yes
+
+GH_ACCOUNT= wulf7
+
+# Strip -Werror from sys/conf/kmod.mk
+MAKE_ENV= WERROR=""
+
+PLIST_FILES= ${KMODDIR}/iichid.ko
+
+# USB backend is not yet complete and
+# interferes with existing USB drivers
+post-patch:
+ ${REINPLACE_CMD} -e '/usbhid.c/s/^/#/' ${WRKSRC}/Makefile
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1201000
+IGNORE= requires FreeBSD versions 12.1+, this system is running ${OSREL}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/iichid/distinfo b/sysutils/iichid/distinfo
new file mode 100644
index 000000000000..f036d586252f
--- /dev/null
+++ b/sysutils/iichid/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1581662226
+SHA256 (wulf7-iichid-0.0.1_GH0.tar.gz) = 282540487df1eb3f202f7beb440f68f43801662cb8f817931f09879c1f007a98
+SIZE (wulf7-iichid-0.0.1_GH0.tar.gz) = 51001
diff --git a/sysutils/iichid/pkg-descr b/sysutils/iichid/pkg-descr
new file mode 100644
index 000000000000..7203d9e4f734
--- /dev/null
+++ b/sysutils/iichid/pkg-descr
@@ -0,0 +1,7 @@
+FreeBSD driver for I2C HID touchscreens (and may be other devices)
+
+A complete discussion about how to use this tool can be found at:
+
+https://larastechlab.blogspot.com/2020/01/i2c-touchpads-on-freebsd-130-current.html
+
+WWW: https://github.com/wulf7/iichid
diff --git a/sysutils/iichid/pkg-message b/sysutils/iichid/pkg-message
new file mode 100644
index 000000000000..b6e9b51239e9
--- /dev/null
+++ b/sysutils/iichid/pkg-message
@@ -0,0 +1,5 @@
+iichid is currently in-development and EXPERIMENTAL. This port provides
+an easy and quick method for users to test this code to encourage early
+testing, feedback and bug reports.
+
+Please report successes and issues to: https://github.com/wulf7/iichid