aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-03-19 01:08:37 +0000
committerSteve Wills <swills@FreeBSD.org>2014-03-19 01:08:37 +0000
commitc80080ba7b99341dd965806869e5b49b55fe97ec (patch)
tree4a2e39891c073c6d4ad7908a5688f962534cf44c /sysutils
parent7bf5d98f745e40aa7ef3f2858d7eebb218acd885 (diff)
downloadports-c80080ba7b99341dd965806869e5b49b55fe97ec.tar.gz
ports-c80080ba7b99341dd965806869e5b49b55fe97ec.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-psutil121/Makefile20
-rw-r--r--sysutils/py-psutil121/distinfo2
-rw-r--r--sysutils/py-psutil121/pkg-descr7
4 files changed, 30 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 218fcd7e6db2..f62f00a1da84 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -736,6 +736,7 @@
SUBDIR += py-nagiosplugin
SUBDIR += py-plumbum
SUBDIR += py-psutil
+ SUBDIR += py-psutil121
SUBDIR += py-pytsk
SUBDIR += py-ranger
SUBDIR += py-salt
diff --git a/sysutils/py-psutil121/Makefile b/sysutils/py-psutil121/Makefile
new file mode 100644
index 000000000000..619453278776
--- /dev/null
+++ b/sysutils/py-psutil121/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ju Pengfei <jupengfei@gmail.com>
+# $FreeBSD$
+
+PORTNAME= psutil
+PORTVERSION= 1.2.1
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 121
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Process utilities module for Python
+
+LICENSE= BSD3CLAUSE
+
+PYDISTUTILS_AUTOPLIST= yes
+USE_PYDISTUTILS=yes
+USE_PYTHON= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-psutil121/distinfo b/sysutils/py-psutil121/distinfo
new file mode 100644
index 000000000000..fe98f49a52db
--- /dev/null
+++ b/sysutils/py-psutil121/distinfo
@@ -0,0 +1,2 @@
+SHA256 (psutil-1.2.1.tar.gz) = 508e4a44c8253a386a0f86d9c9bd4a1b4cbb2f94e88d49a19c1513653ca66c45
+SIZE (psutil-1.2.1.tar.gz) = 167397
diff --git a/sysutils/py-psutil121/pkg-descr b/sysutils/py-psutil121/pkg-descr
new file mode 100644
index 000000000000..335bf2c59149
--- /dev/null
+++ b/sysutils/py-psutil121/pkg-descr
@@ -0,0 +1,7 @@
+psutil is a module providing an interface for retrieving information
+on running processes and system utilization (CPU, memory) in a portable
+way by using Python, implementing many functionalities offered by tools
+like ps, top and Windows task manager.
+
+WWW: http://code.google.com/p/psutil/
+WWW: http://pypi.python.org/pypi/psutil/