aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-10-17 20:35:26 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-10-17 20:35:26 +0000
commitd53990bd73f1f03b15cc8bbf4ab97969a3517a3c (patch)
tree1dc63f7918ab14e5d4555480ddcb710ba572e135 /sysutils
parent154dcf45c2f91cde9d05b76e38e06ecbf315ee5c (diff)
downloadports-d53990bd73f1f03b15cc8bbf4ab97969a3517a3c.tar.gz
ports-d53990bd73f1f03b15cc8bbf4ab97969a3517a3c.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/amtc/Makefile31
-rw-r--r--sysutils/amtc/distinfo2
-rw-r--r--sysutils/amtc/files/patch-Makefile31
-rw-r--r--sysutils/amtc/pkg-descr13
-rw-r--r--sysutils/amtc/pkg-plist77
6 files changed, 155 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index b4fedd8a65c5..468fe341bc2e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -27,6 +27,7 @@
SUBDIR += aird
SUBDIR += am-utils
SUBDIR += amrstat
+ SUBDIR += amtc
SUBDIR += anacron
SUBDIR += and
SUBDIR += ansible
diff --git a/sysutils/amtc/Makefile b/sysutils/amtc/Makefile
new file mode 100644
index 000000000000..2bfbe5d83e77
--- /dev/null
+++ b/sysutils/amtc/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= amtc
+PORTVERSION= 0.8.4
+CATEGORIES= sysutils
+
+MAINTAINER= tony.li@tony.li
+COMMENT= Threaded Intel AMT/vPro mass management tool
+
+LICENSE= CC3.0
+LICENSE_NAME= Creative Commons Attribution 3.0 Unported
+LICENSE_TEXT= http://creativecommons.org/licenses/by/3.0/
+LICENSE_PERMS= auto-accept pkg-sell pkg-mirror dist-sell dist-mirror
+
+BUILD_DEPENDS= xxd:${PORTSDIR}/editors/vim-lite
+LIB_DEPENDS+= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libcurl.so:${PORTSDIR}/ftp/curl
+
+USES= perl5 shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= schnoddelbotz
+GH_TAGNAME= e7822e8
+USE_PERL5= build
+SHEBANG_FILES= ${WRKSRC}/../amtc-web/cli/amtc-web.phpsh
+
+WRKSRC_SUBDIR= src
+
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/amtc
+
+.include <bsd.port.mk>
diff --git a/sysutils/amtc/distinfo b/sysutils/amtc/distinfo
new file mode 100644
index 000000000000..ec1e03ca84c7
--- /dev/null
+++ b/sysutils/amtc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (schnoddelbotz-amtc-0.8.4-e7822e8_GH0.tar.gz) = 9fdbcfd2b10e87d0363b2b8498779f35d864ff29596ee15994f0c55ef9595abb
+SIZE (schnoddelbotz-amtc-0.8.4-e7822e8_GH0.tar.gz) = 1503968
diff --git a/sysutils/amtc/files/patch-Makefile b/sysutils/amtc/files/patch-Makefile
new file mode 100644
index 000000000000..319b60bf9f4f
--- /dev/null
+++ b/sysutils/amtc/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- Makefile.orig 2015-05-04 22:53:09 UTC
++++ Makefile
+@@ -4,8 +4,8 @@
+ #
+ # Makefile for amtc
+
+-LDLIBS=-lcurl -lpthread
+-CFLAGS=-I. -Wall
++LDLIBS=-L/usr/local/lib -lcurl -lpthread
++CFLAGS=-I/usr/local/include -I. -Wall
+ AMTCV=$(shell cat ../version)
+ APP=amtc-$(AMTCV)
+ OS=$(shell uname -s)
+@@ -18,6 +18,8 @@ HEADERS=amtc_usage cmd_powerdown cmd_pow
+ wsman_ping_enable wsman_ping_disable \
+ wsman_shutdown_graceful
+
++all: amtc
++
+ amtc: amtc.c
+
+ amtc.c: amt.h
+@@ -34,3 +36,8 @@ amt.h:
+ clean:
+ rm -f cmd_*.h wsman_*.h amtc_usage.h amt.h amtc *.o
+
++install:
++ mkdir -p $(DESTDIR)$(PREFIX)/bin $(DESTDIR)$(PREFIX)/www
++ $(INSTALL) -c amtc $(DESTDIR)$(PREFIX)/bin
++ /bin/cp -R ../amtc-web $(DESTDIR)$(PREFIX)/www
++
diff --git a/sysutils/amtc/pkg-descr b/sysutils/amtc/pkg-descr
new file mode 100644
index 000000000000..a2013a464d4f
--- /dev/null
+++ b/sysutils/amtc/pkg-descr
@@ -0,0 +1,13 @@
+Intel's Active Management Technology is a simple embedded subsystem
+that helps you manage remote servers. In particular you can power off
+or reset a remote system, regardless of the state of the operating
+system.
+
+amtc is a tool to efficiently monitor, power-control on a scheduled
+basis and interactively manage a bigger bunch of PCs equipped with
+Intel vPro technology, distributed over several rooms. Having a
+practical tool for this purpose massively eases system management
+procedures, from scheduled, unattended OS-re-installs to individual,
+interactive remote power management needs.
+
+WWW: https://github.com/schnoddelbotz/amtc
diff --git a/sysutils/amtc/pkg-plist b/sysutils/amtc/pkg-plist
new file mode 100644
index 000000000000..4b22cc586bd5
--- /dev/null
+++ b/sysutils/amtc/pkg-plist
@@ -0,0 +1,77 @@
+bin/amtc
+%%WWWDIR%%-web/LICENSES-3rd-party.txt
+%%WWWDIR%%-web/Makefile
+%%WWWDIR%%-web/Makefile.Sources
+%%WWWDIR%%-web/_htaccess_example
+%%WWWDIR%%-web/_httpd_conf_example
+%%WWWDIR%%-web/amtc-favicon.png
+%%WWWDIR%%-web/basic-auth/_htaccess.default
+%%WWWDIR%%-web/basic-auth/index.html
+%%WWWDIR%%-web/cli/amtc-web.phpsh
+%%WWWDIR%%-web/config/_htpasswd.default
+%%WWWDIR%%-web/crontab-example.txt
+%%WWWDIR%%-web/css/amtc-web.css
+%%WWWDIR%%-web/data/.htaccess
+%%WWWDIR%%-web/js/app/app.js
+%%WWWDIR%%-web/js/compile-template.js
+%%WWWDIR%%-web/lib/AmtcwebInstaller.php
+%%WWWDIR%%-web/lib/AmtcwebSpooler.php
+%%WWWDIR%%-web/lib/app_bootstrap.php
+%%WWWDIR%%-web/lib/db-model/host.php
+%%WWWDIR%%-web/lib/db-model/job.php
+%%WWWDIR%%-web/lib/db-model/laststate.php
+%%WWWDIR%%-web/lib/db-model/logday.php
+%%WWWDIR%%-web/lib/db-model/notification.php
+%%WWWDIR%%-web/lib/db-model/optionset.php
+%%WWWDIR%%-web/lib/db-model/ou.php
+%%WWWDIR%%-web/lib/db-model/statelog.php
+%%WWWDIR%%-web/lib/db-model/user.php
+%%WWWDIR%%-web/lib/install-db/mysql-exampledata.sql
+%%WWWDIR%%-web/lib/install-db/mysql-minimal.sql
+%%WWWDIR%%-web/lib/install-db/mysql.sql
+%%WWWDIR%%-web/lib/install-db/sqlite-exampledata.sql
+%%WWWDIR%%-web/lib/install-db/sqlite-minimal.sql
+%%WWWDIR%%-web/lib/install-db/sqlite.sql
+%%WWWDIR%%-web/pages/about.md
+%%WWWDIR%%-web/pages/configure-amt.md
+%%WWWDIR%%-web/pages/first-steps.md
+%%WWWDIR%%-web/rest-api.php
+%%WWWDIR%%-web/templates/_optionsetEdit.hbs.html
+%%WWWDIR%%-web/templates/_ouSelection.hbs.html
+%%WWWDIR%%-web/templates/_scheduleEdit.hbs.html
+%%WWWDIR%%-web/templates/_userEdit.hbs.html
+%%WWWDIR%%-web/templates/addHostsWizard.hbs.html
+%%WWWDIR%%-web/templates/application.hbs.html
+%%WWWDIR%%-web/templates/application_footer.html
+%%WWWDIR%%-web/templates/application_header.html
+%%WWWDIR%%-web/templates/components/state-log.hbs.html
+%%WWWDIR%%-web/templates/components/tree-menu-node.hbs.html
+%%WWWDIR%%-web/templates/energy.hbs.html
+%%WWWDIR%%-web/templates/index.hbs.html
+%%WWWDIR%%-web/templates/login.hbs.html
+%%WWWDIR%%-web/templates/logout.hbs.html
+%%WWWDIR%%-web/templates/logs.hbs.html
+%%WWWDIR%%-web/templates/navigation.hbs.html
+%%WWWDIR%%-web/templates/optionset.hbs.html
+%%WWWDIR%%-web/templates/optionsets.hbs.html
+%%WWWDIR%%-web/templates/optionsets/index.hbs.html
+%%WWWDIR%%-web/templates/optionsets/new.hbs.html
+%%WWWDIR%%-web/templates/ou.hbs.html
+%%WWWDIR%%-web/templates/ou/edit.hbs.html
+%%WWWDIR%%-web/templates/ou/hosts.hbs.html
+%%WWWDIR%%-web/templates/ou/monitor.hbs.html
+%%WWWDIR%%-web/templates/ou/statelog.hbs.html
+%%WWWDIR%%-web/templates/ous.hbs.html
+%%WWWDIR%%-web/templates/ous/index.hbs.html
+%%WWWDIR%%-web/templates/ous/new.hbs.html
+%%WWWDIR%%-web/templates/page.hbs.html
+%%WWWDIR%%-web/templates/schedule.hbs.html
+%%WWWDIR%%-web/templates/schedules.hbs.html
+%%WWWDIR%%-web/templates/schedules/index.hbs.html
+%%WWWDIR%%-web/templates/schedules/new.hbs.html
+%%WWWDIR%%-web/templates/setup.hbs.html
+%%WWWDIR%%-web/templates/systemhealth.hbs.html
+%%WWWDIR%%-web/templates/user/edit.hbs.html
+%%WWWDIR%%-web/templates/users.hbs.html
+%%WWWDIR%%-web/templates/users/index.hbs.html
+%%WWWDIR%%-web/templates/users/new.hbs.html