aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-08-21 22:14:30 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-08-21 22:14:30 +0000
commiteae381f33aba4a89599455d86cb36d785cf30f15 (patch)
tree72f6da7ea59515c7a7098f932b625d5cca84bb68 /sysutils
parentcb8dc6637fda1cd05d7749d55990aa1ef65b2055 (diff)
downloadports-eae381f33aba4a89599455d86cb36d785cf30f15.tar.gz
ports-eae381f33aba4a89599455d86cb36d785cf30f15.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/bbcp/Makefile35
-rw-r--r--sysutils/bbcp/distinfo4
-rw-r--r--sysutils/bbcp/pkg-descr3
4 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 134ccd3297ad..035d2a8d03bb 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -65,6 +65,7 @@
SUBDIR += battmond
SUBDIR += battray
SUBDIR += bbapm
+ SUBDIR += bbcp
SUBDIR += bchunk
SUBDIR += be_agent
SUBDIR += beadm
diff --git a/sysutils/bbcp/Makefile b/sysutils/bbcp/Makefile
new file mode 100644
index 000000000000..f7ee03961e70
--- /dev/null
+++ b/sysutils/bbcp/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: bbcp
+# Date created: 10 August 2012
+# Whom: John Hein <jhein@symmetricom.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bbcp
+PORTVERSION= 20120520
+CATEGORIES= sysutils net
+MASTER_SITES= https://bitbucket.org/jhein/bbcp/downloads/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}-20100818.pdf
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= jhein@symmetricom.com
+COMMENT= Secure and fast copy utility
+
+LICENSE= BSD
+
+BUILD_WRKSRC= ${WRKSRC}/src
+FETCH_ARGS= -Fpr
+PLIST_FILES= bin/bbcp
+PORTDOCS= ${PORTNAME}.pdf
+USE_XZ= yes
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/bbcp ${PREFIX}/bin
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}-20100818.pdf ${DOCSDIR}/${PORTNAME}.pdf
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/bbcp/distinfo b/sysutils/bbcp/distinfo
new file mode 100644
index 000000000000..9d462fee5c0a
--- /dev/null
+++ b/sysutils/bbcp/distinfo
@@ -0,0 +1,4 @@
+SHA256 (bbcp-20120520.tar.xz) = 9d4c59ca08b6a40b96b4240ee836c09ccae4407149c21eb259d6ecd0ddf599e2
+SIZE (bbcp-20120520.tar.xz) = 109104
+SHA256 (bbcp-20100818.pdf) = c5910d9a75eefea639f6d88282709d8882d68927137babd5ec851e1c17dcbeae
+SIZE (bbcp-20100818.pdf) = 889566
diff --git a/sysutils/bbcp/pkg-descr b/sysutils/bbcp/pkg-descr
new file mode 100644
index 000000000000..b1e0447baf9b
--- /dev/null
+++ b/sysutils/bbcp/pkg-descr
@@ -0,0 +1,3 @@
+Securely and quickly copy data from source to target.
+
+WWW: http://www.slac.stanford.edu/~abh/bbcp/