aboutsummaryrefslogtreecommitdiff
path: root/textproc/agrep
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-07-21 01:56:56 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-07-21 01:56:56 +0000
commit8d5699d7adf485d848ec5b5d50459db383e0a125 (patch)
treeb26dc1c2878c0975b8b9137ca697e167658b3529 /textproc/agrep
parent0b11a525c573874467c29233f4503f8b99b6ed3e (diff)
downloadports-8d5699d7adf485d848ec5b5d50459db383e0a125.tar.gz
ports-8d5699d7adf485d848ec5b5d50459db383e0a125.zip
* Honor CFLAGS.
* Include proper prototypes; fixes dire warnings on alpha.
Notes
Notes: svn path=/head/; revision=63295
Diffstat (limited to 'textproc/agrep')
-rw-r--r--textproc/agrep/Makefile2
-rw-r--r--textproc/agrep/files/patch-agrep.h18
-rw-r--r--textproc/agrep/files/patch-follow.c22
-rw-r--r--textproc/agrep/files/patch-mgrep.c13
-rw-r--r--textproc/agrep/files/patch-parse.c13
-rw-r--r--textproc/agrep/files/patch-sgrep.c12
-rw-r--r--textproc/agrep/files/patch-utilities.c13
7 files changed, 93 insertions, 0 deletions
diff --git a/textproc/agrep/Makefile b/textproc/agrep/Makefile
index 8ea655baebc3..22c42deeff4b 100644
--- a/textproc/agrep/Makefile
+++ b/textproc/agrep/Makefile
@@ -16,6 +16,8 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
ALL_TARGET=
+MAKE_ARGS= CFLAGS="${CFLAGS}"
+
MAN1= agrep.1
do-install:
diff --git a/textproc/agrep/files/patch-agrep.h b/textproc/agrep/files/patch-agrep.h
new file mode 100644
index 000000000000..7d6299ce4387
--- /dev/null
+++ b/textproc/agrep/files/patch-agrep.h
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- agrep.h.orig Fri Jan 17 20:15:13 1992
++++ agrep.h Sun Jul 21 03:50:47 2002
+@@ -1,10 +1,10 @@
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <math.h>
+ #include <ctype.h>
+ #include "re.h"
+
+-extern unsigned char *strcpy(), *strncpy(), *strcat();
+-extern int strlen();
+ #define CHAR unsigned char
+ #define MAXPAT 128
+ #define MAXPATT 256
diff --git a/textproc/agrep/files/patch-follow.c b/textproc/agrep/files/patch-follow.c
new file mode 100644
index 000000000000..5bdf13a7714c
--- /dev/null
+++ b/textproc/agrep/files/patch-follow.c
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- follow.c.orig Fri Jan 17 20:14:42 1992
++++ follow.c Sun Jul 21 03:50:47 2002
+@@ -3,14 +3,12 @@
+ construction. */
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include "re.h"
+
+-extern char *strncpy(), *strcat(), *strcpy();
+-extern int strlen();
+-
+ #define TRUE 1
+
+-extern char *malloc();
+ extern Pset pset_union();
+ extern int pos_cnt;
+ extern Re_node parse();
diff --git a/textproc/agrep/files/patch-mgrep.c b/textproc/agrep/files/patch-mgrep.c
new file mode 100644
index 000000000000..439326807c9f
--- /dev/null
+++ b/textproc/agrep/files/patch-mgrep.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- mgrep.c.orig Sat Apr 11 00:12:27 1992
++++ mgrep.c Sun Jul 21 03:50:47 2002
+@@ -1,6 +1,7 @@
+ /* Copyright (c) 1991 Sun Wu and Udi Manber. All Rights Reserved. */
+ /* multipattern matcher */
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <ctype.h>
+ #define MAXPAT 256
+ #define MAXLINE 1024
diff --git a/textproc/agrep/files/patch-parse.c b/textproc/agrep/files/patch-parse.c
new file mode 100644
index 000000000000..fe687b8ef9a4
--- /dev/null
+++ b/textproc/agrep/files/patch-parse.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- parse.c.orig Fri Jan 17 20:14:43 1992
++++ parse.c Sun Jul 21 03:50:47 2002
+@@ -3,6 +3,7 @@
+ tree for that regular expression. */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "re.h"
+
+ #define FALSE 0
diff --git a/textproc/agrep/files/patch-sgrep.c b/textproc/agrep/files/patch-sgrep.c
new file mode 100644
index 000000000000..bd2f06baad7b
--- /dev/null
+++ b/textproc/agrep/files/patch-sgrep.c
@@ -0,0 +1,12 @@
+
+$FreeBSD$
+
+--- sgrep.c.orig Sat Apr 11 00:12:02 1992
++++ sgrep.c Sun Jul 21 03:50:47 2002
+@@ -1,5 +1,6 @@
+ /* Copyright (c) 1991 Sun Wu and Udi Manber. All Rights Reserved. */
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <ctype.h>
+ #define MAXSYM 256
+ #define MAXMEMBER 8192
diff --git a/textproc/agrep/files/patch-utilities.c b/textproc/agrep/files/patch-utilities.c
new file mode 100644
index 000000000000..df61cfc7717b
--- /dev/null
+++ b/textproc/agrep/files/patch-utilities.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- utilities.c.orig Fri Jan 17 20:14:43 1992
++++ utilities.c Sun Jul 21 03:50:47 2002
+@@ -2,6 +2,7 @@
+ and manipulating regular expression syntax trees. */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "re.h"
+
+ /************************************************************************/