aboutsummaryrefslogtreecommitdiff
path: root/textproc/agrep
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-06-27 04:05:34 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-06-27 04:05:34 +0000
commitff0000c3199db66c1beae9a6fb7312d00156314f (patch)
tree4a88fd4783a61195777962d3c47d7b96bc3e9471 /textproc/agrep
parent6c899e1043564cb4adcda18843127978c088d5d9 (diff)
downloadports-ff0000c3199db66c1beae9a6fb7312d00156314f.tar.gz
ports-ff0000c3199db66c1beae9a6fb7312d00156314f.zip
Fix missing format string argument and bump PORTREVISION.
Obtained from: OpenBSD
Notes
Notes: svn path=/head/; revision=83709
Diffstat (limited to 'textproc/agrep')
-rw-r--r--textproc/agrep/Makefile1
-rw-r--r--textproc/agrep/files/patch-mgrep.c16
2 files changed, 12 insertions, 5 deletions
diff --git a/textproc/agrep/Makefile b/textproc/agrep/Makefile
index f2cd27fea520..c0d63dbf4459 100644
--- a/textproc/agrep/Makefile
+++ b/textproc/agrep/Makefile
@@ -8,6 +8,7 @@
PORTNAME= agrep
PORTVERSION= 2.04
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ftp://ftp.cs.arizona.edu/agrep/
EXTRACT_SUFX= .tar.Z
diff --git a/textproc/agrep/files/patch-mgrep.c b/textproc/agrep/files/patch-mgrep.c
index 439326807c9f..d7ac5b9730c8 100644
--- a/textproc/agrep/files/patch-mgrep.c
+++ b/textproc/agrep/files/patch-mgrep.c
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- mgrep.c.orig Sat Apr 11 00:12:27 1992
-+++ mgrep.c Sun Jul 21 03:50:47 2002
+--- mgrep.c.orig Thu Jun 26 21:03:50 2003
++++ mgrep.c Thu Jun 26 21:03:53 2003
@@ -1,6 +1,7 @@
/* Copyright (c) 1991 Sun Wu and Udi Manber. All Rights Reserved. */
/* multipattern matcher */
@@ -11,3 +8,12 @@ $FreeBSD$
#include <ctype.h>
#define MAXPAT 256
#define MAXLINE 1024
+@@ -85,7 +86,7 @@
+ if(p!=0 && p < p_size) p_size = p;
+ }
+ if(p_size == 0) {
+- fprintf(stderr, "%s: the pattern file is empty\n");
++ fprintf(stderr, "%s: the pattern file is empty\n", Progname);
+ exit(2);
+ }
+ if(length > 400 && p_size > 2) LONG = 1;