aboutsummaryrefslogtreecommitdiff
path: root/textproc/aiksaurus
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-07-23 20:46:56 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-07-23 20:46:56 +0000
commit33a0a1739517d70b2d8b9e7a783e996797c72ca6 (patch)
treedf11950239c026f0ca3c111adc1d75cfc2394fe8 /textproc/aiksaurus
parentb78a6067e6335f9c27ea1cc6d3255409a3857b68 (diff)
downloadports-33a0a1739517d70b2d8b9e7a783e996797c72ca6.tar.gz
ports-33a0a1739517d70b2d8b9e7a783e996797c72ca6.zip
Aiksaurus is a set of libraries and applications which provide a thesaurus
(currently English only, based on Guttenburg's Moby thesaurus) using native GUI on several platforms: UNIX (GTK+ & Qt), Win32 & MacOSX (Cocoa). The core library itself is platform-independent. The principal language is C++, with some use of Cocoa/ObjC++; wrappers are provided for C and Cocoa/ObjC. Aiksausus plugins exist for AbiWord on UNIX and Win32; the library is also used by Lyx; and the new Cocoa port provides a MacOSX NSService hook so that Safari and other such applications can use this thesaurus without Aiksaurus-specific development. WWW: http://aiksaurus.sourceforge.net/
Notes
Notes: svn path=/head/; revision=114522
Diffstat (limited to 'textproc/aiksaurus')
-rw-r--r--textproc/aiksaurus/Makefile25
-rw-r--r--textproc/aiksaurus/distinfo2
-rw-r--r--textproc/aiksaurus/pkg-descr12
-rw-r--r--textproc/aiksaurus/pkg-plist13
4 files changed, 52 insertions, 0 deletions
diff --git a/textproc/aiksaurus/Makefile b/textproc/aiksaurus/Makefile
new file mode 100644
index 000000000000..a11f9192a79b
--- /dev/null
+++ b/textproc/aiksaurus/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: aiksaurus
+# Date created: 23 July 2004
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aiksaurus
+PORTVERSION= 1.2.1
+PORTREVISION?= 0
+CATEGORIES?= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= aiksaurus
+
+MAINTAINER?= gnome@FreeBSD.org
+COMMENT?= A set of libraries and applications which provide a thesaurus
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnometarget
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ARGS?=--without-gtk
+
+.include <bsd.port.mk>
diff --git a/textproc/aiksaurus/distinfo b/textproc/aiksaurus/distinfo
new file mode 100644
index 000000000000..3a2e1559ba77
--- /dev/null
+++ b/textproc/aiksaurus/distinfo
@@ -0,0 +1,2 @@
+MD5 (aiksaurus-1.2.1.tar.gz) = 3eae03b7c49843ccc9262e52846ea6b4
+SIZE (aiksaurus-1.2.1.tar.gz) = 928893
diff --git a/textproc/aiksaurus/pkg-descr b/textproc/aiksaurus/pkg-descr
new file mode 100644
index 000000000000..33868e6f0a05
--- /dev/null
+++ b/textproc/aiksaurus/pkg-descr
@@ -0,0 +1,12 @@
+Aiksaurus is a set of libraries and applications which provide a thesaurus
+(currently English only, based on Guttenburg's Moby thesaurus) using native
+GUI on several platforms: UNIX (GTK+ & Qt), Win32 & MacOSX (Cocoa). The core
+library itself is platform-independent. The principal language is C++, with
+some use of Cocoa/ObjC++; wrappers are provided for C and Cocoa/ObjC.
+
+Aiksausus plugins exist for AbiWord on UNIX and Win32; the library is also
+used by Lyx; and the new Cocoa port provides a MacOSX NSService hook so that
+Safari and other such applications can use this thesaurus without
+Aiksaurus-specific development.
+
+WWW: http://aiksaurus.sourceforge.net/
diff --git a/textproc/aiksaurus/pkg-plist b/textproc/aiksaurus/pkg-plist
new file mode 100644
index 000000000000..26e086a91b39
--- /dev/null
+++ b/textproc/aiksaurus/pkg-plist
@@ -0,0 +1,13 @@
+bin/aiksaurus
+bin/caiksaurus
+include/Aiksaurus/Aiksaurus.h
+include/Aiksaurus/AiksaurusC.h
+lib/libAiksaurus-1.2.so
+lib/libAiksaurus-1.2.so.0
+lib/libAiksaurus.a
+lib/libAiksaurus.so
+libdata/pkgconfig/aiksaurus-1.0.pc
+share/aiksaurus/meanings.dat
+share/aiksaurus/words.dat
+@dirrm share/aiksaurus
+@dirrm include/Aiksaurus