aboutsummaryrefslogtreecommitdiff
path: root/textproc/asciidoc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-06 15:35:50 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-06 15:35:50 +0000
commit61191d403eafbcac8897288a00ddfdfdf7ef8fa7 (patch)
tree9251c01eec94fa0b4acff682a9f3345980c36cb7 /textproc/asciidoc
parent123e9ffe790e9ebd048afcb30152dcd50491923a (diff)
downloadports-61191d403eafbcac8897288a00ddfdfdf7ef8fa7.tar.gz
ports-61191d403eafbcac8897288a00ddfdfdf7ef8fa7.zip
Avoid using /usr/local directly and stop false alarm in stage-qa:
====> Running Q/A tests (stage-qa) Warning: Possible REINPLACE_CMD issues: - - REINPLACE_CMD ran, but did not modify file contents: a2x.py
Notes
Notes: svn path=/head/; revision=547804
Diffstat (limited to 'textproc/asciidoc')
-rw-r--r--textproc/asciidoc/Makefile2
-rw-r--r--textproc/asciidoc/files/patch-a2x.py2
2 files changed, 2 insertions, 2 deletions
diff --git a/textproc/asciidoc/Makefile b/textproc/asciidoc/Makefile
index c98dc22a82ee..f9542eb30c4a 100644
--- a/textproc/asciidoc/Makefile
+++ b/textproc/asciidoc/Makefile
@@ -25,7 +25,7 @@ SHEBANG_GLOB= *.py
post-patch:
@${REINPLACE_CMD} -e 's|python3 |${PYTHON_CMD} |' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/a2x.py
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/a2x.py
@${FIND} ${WRKSRC} -name '*.conf' | ${XARGS} -I % ${LN} % %.sample
post-install:
diff --git a/textproc/asciidoc/files/patch-a2x.py b/textproc/asciidoc/files/patch-a2x.py
index 66089a0d8daa..570e532ca13e 100644
--- a/textproc/asciidoc/files/patch-a2x.py
+++ b/textproc/asciidoc/files/patch-a2x.py
@@ -5,7 +5,7 @@
for attr in self.attributes:
self.asciidoc_opts += ' --attribute "%s"' % attr
-# self.xsltproc_opts += ' --nonet'
-+ self.xsltproc_opts += ' --nonet --path /usr/local/share/xsl/docbook/manpages/'
++ self.xsltproc_opts += ' --nonet --path %%LOCALBASE%%/share/xsl/docbook/manpages/'
if self.verbose:
self.asciidoc_opts += ' --verbose'
self.dblatex_opts += ' -V'