aboutsummaryrefslogtreecommitdiff
path: root/textproc/asciidoc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-01-06 15:11:48 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-01-06 15:11:48 +0000
commit9958ccb34565d49fc1402bda7ac3bb7863e0d08c (patch)
tree7df8ec28a8018a774b55745b3db7bfd501225f5b /textproc/asciidoc
parent3ceb872daa0305391269f32984d3cb61bb64ed16 (diff)
downloadports-9958ccb34565d49fc1402bda7ac3bb7863e0d08c.tar.gz
ports-9958ccb34565d49fc1402bda7ac3bb7863e0d08c.zip
- Install asciidocapi.py
- Bump PORTREVISION for package change - While I'm here, fix shebang PR: ports/185107 Submitted by: Kevin Zheng <kevinz5000@gmail.com>
Notes
Notes: svn path=/head/; revision=338893
Diffstat (limited to 'textproc/asciidoc')
-rw-r--r--textproc/asciidoc/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/textproc/asciidoc/Makefile b/textproc/asciidoc/Makefile
index 8a5343f5b2be..ba9e762372f4 100644
--- a/textproc/asciidoc/Makefile
+++ b/textproc/asciidoc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= asciidoc
PORTVERSION= 8.6.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF
@@ -17,7 +17,7 @@ RUN_DEPENDS= python2:${PORTSDIR}/lang/python2
GNU_CONFIGURE= yes
USE_PYTHON= -2.7
-USES= gmake
+USES= gmake shebangfix
CONF_FILES= asciidoc.conf docbook45.conf filters/code/code-filter.conf \
filters/graphviz/graphviz-filter.conf \
@@ -30,14 +30,25 @@ CONF_FILES= asciidoc.conf docbook45.conf filters/code/code-filter.conf \
lang-ru.conf lang-uk.conf latex.conf slidy.conf text.conf \
xhtml11.conf xhtml11-quirks.conf
+SHEBANG_FILES= a2x.py \
+ asciidoc.py \
+ asciidocapi.py \
+ filters/latex/latex2png.py \
+ filters/graphviz/graphviz2png.py \
+ filters/music/music2png.py \
+ filters/code/code-filter.py
+python_OLD_CMD= ${SETENV} python
+python_CMD= ${PYTHON_CMD}
+
post-patch:
@${REINPLACE_CMD} -e '/^INSTALL_PROG/ s|INSTALL_PROGRAM|INSTALL_SCRIPT|; s|\.conf|&.sample|' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e '1 s|${SETENV} python|&2|' ${WRKSRC}/a2x.py ${WRKSRC}/asciidoc.py
.for conf_file in ${CONF_FILES}
@cd ${WRKSRC}/ && ${MV} ${conf_file} ${conf_file}.sample
.endfor
post-install:
+ ${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/asciidocapi.py ${STAGEDIR}${PYTHON_SITELIBDIR}/
.for conf_file in ${CONF_FILES}
@if [ ! -f ${ETCDIR}/${conf_file} ]; then \
${CP} -p ${STAGEDIR}${ETCDIR}/${conf_file}.sample ${STAGEDIR}${ETCDIR}/${conf_file}; \