aboutsummaryrefslogtreecommitdiff
path: root/textproc/asciidoc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-25 08:04:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-25 08:04:55 +0000
commit9fafb3898f13a4d9b661c96db5e8d541fff27e52 (patch)
tree5cf2760b2747297c0e237ef090e7e67aa63d3159 /textproc/asciidoc
parentc5d0ef85f77a059584b4e6579adc73ab7f5d0dff (diff)
downloadports-9fafb3898f13a4d9b661c96db5e8d541fff27e52.tar.gz
ports-9fafb3898f13a4d9b661c96db5e8d541fff27e52.zip
- Add option: VIM for vim ftdetect & syntax files
- Cleanup Makefile header - Take maintainership - Fix PLIST: remove blank line
Notes
Notes: svn path=/head/; revision=325329
Diffstat (limited to 'textproc/asciidoc')
-rw-r--r--textproc/asciidoc/Makefile30
-rw-r--r--textproc/asciidoc/pkg-plist14
2 files changed, 33 insertions, 11 deletions
diff --git a/textproc/asciidoc/Makefile b/textproc/asciidoc/Makefile
index 858f86976d97..5b6412ec1849 100644
--- a/textproc/asciidoc/Makefile
+++ b/textproc/asciidoc/Makefile
@@ -7,17 +7,21 @@ PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Text document format for writing short documents and man pages
LICENSE= GPLv2 MIT
LICENSE_COMB= multi
-RUN_DEPENDS+= python2:${PORTSDIR}/lang/python2
+RUN_DEPENDS= python2:${PORTSDIR}/lang/python2
+
+OPTIONS_DEFINE= VIM
+OPTIONS_DEFAULT=VIM
+VIM_DESC= Install Vim ftdetect & syntax files
-USE_PYTHON= -2.7
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_PYTHON= -2.7
+USES= gmake
MAN1= a2x.1 asciidoc.1
@@ -34,10 +38,28 @@ CONFFILES= asciidoc.conf docbook45.conf \
latex.conf slidy.conf text.conf wordpress.conf \
xhtml11.conf xhtml11-quirks.conf
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MVIM}
+MAKE_ENV+= vimdir=${PREFIX}/share/vim/${VIM_DATADIR}
+PLIST_SUB+= VIM="" VIM_DATADIR=${VIM_DATADIR}
+VIM__DATADIR!= ${MAKE} -C ../../editors/vim/ -V _DATADIR
+.else
+PLIST_SUB+= VIM="@comment " VIM_DATADIR=""
+.endif
+
post-patch:
.for f in ${CONFFILES}
@cd ${WRKSRC} && ${MV} ${f} ${f}.sample
.endfor
+.if ${PORT_OPTIONS:MVIM}
+ @${REINPLACE_CMD} -e '/^vimdir = /d' ${WRKSRC}/Makefile.in
+.endif
+
+pre-install:
+.if ${PORT_OPTIONS:MVIM}
+ @${MKDIR} ${PREFIX}/share/vim/${VIM_DATADIR}/
+.endif
post-install:
.for f in ${CONFFILES}
diff --git a/textproc/asciidoc/pkg-plist b/textproc/asciidoc/pkg-plist
index 0c0dfacf7ed2..6c8f9ee21a94 100644
--- a/textproc/asciidoc/pkg-plist
+++ b/textproc/asciidoc/pkg-plist
@@ -131,17 +131,17 @@ bin/asciidoc.py
%%ETCDIR%%/wordpress.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/wordpress.conf ] ; then cp -p %D/%F %B/wordpress.conf; fi
@unexec if cmp -s %D/%%ETCDIR%%/xhtml11.conf.sample %D/%%ETCDIR%%/xhtml11.conf; then rm -f %D/%%ETCDIR%%/xhtml11.conf; fi
-%%ETCDIR%%/xhtml11.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/xhtml11.conf ] ; then cp -p %D/%F %B/xhtml11.conf; fi
+%%ETCDIR%%/xhtml11.conf.sample
@unexec if cmp -s %D/%%ETCDIR%%/xhtml11-quirks.conf.sample %D/%%ETCDIR%%/xhtml11-quirks.conf; then rm -f %D/%%ETCDIR%%/xhtml11-quirks.conf; fi
%%ETCDIR%%/xhtml11-quirks.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/xhtml11-quirks.conf ] ; then cp -p %D/%F %B/xhtml11-quirks.conf; fi
-share/vim/vimfiles/ftdetect/asciidoc_filetype.vim
-share/vim/vimfiles/syntax/asciidoc.vim
-@dirrmtry share/vim/vimfiles/syntax
-@dirrmtry share/vim/vimfiles/ftdetect
-@dirrmtry share/vim/vimfiles
-@dirrmtry share/vim
+%%VIM%%%%VIM_DATADIR%%share/vim/ftdetect/asciidoc_filetype.vim
+%%VIM%%%%VIM_DATADIR%%share/vim/syntax/asciidoc.vim
+%%VIM%%@dirrmtry share/vim/%%VIM_DATADIR%%/syntax
+%%VIM%%@dirrmtry share/vim/%%VIM_DATADIR%%/ftdetect
+%%VIM%%@dirrmtry share/vim/%%VIM_DATADIR%%
+%%VIM%%@dirrmtry share/vim
@dirrm %%ETCDIR%%/themes/volnitsky
@dirrm %%ETCDIR%%/themes/flask
@dirrm %%ETCDIR%%/themes