aboutsummaryrefslogtreecommitdiff
path: root/textproc/asciidoc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-20 19:48:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-20 19:48:53 +0000
commitfcf5539093c5646abd929fe7c6af4529e08e6f9d (patch)
tree897aa0953f3d39f3f657c811d4f8a1a26a7a9570 /textproc/asciidoc
parent11aa874ee217c280b18995ebf9afc51651ae7e26 (diff)
downloadports-fcf5539093c5646abd929fe7c6af4529e08e6f9d.tar.gz
ports-fcf5539093c5646abd929fe7c6af4529e08e6f9d.zip
Use config newline setting in system attribute evaluation
- Bump PORTREVISION for package change It fixes comms/fldigi build without extra \r removal. Problems seen with inconsistent newlines in the Table Of Contents HTML pulled in from the configuration file. While the rest of the contents in the resulting HTML file honored the newline style configured by the user, this specific snippet of HTML always used "\r\n". This root of this problem existed for some time, but in earlier versions, the newline style was always "\n". The symptoms changed as a side effect of the issue "Extra line padding in source and literal blocks". In this issue, the newline style changed to "\r\n", and was noticed by users. Change the System Attribute Evaluation function to use the newline setting from the global "config" instead of using the default newline. PR: 251329 Reported by: db Obtained from: https://github.com/asciidoc/asciidoc-py3/commit/8313e45cc78af30bb8df5d33311a7f2fdc50595c
Notes
Notes: svn path=/head/; revision=558767
Diffstat (limited to 'textproc/asciidoc')
-rw-r--r--textproc/asciidoc/Makefile1
-rw-r--r--textproc/asciidoc/files/patch-asciidoc.py13
2 files changed, 14 insertions, 0 deletions
diff --git a/textproc/asciidoc/Makefile b/textproc/asciidoc/Makefile
index 2d1872599686..a8306d188552 100644
--- a/textproc/asciidoc/Makefile
+++ b/textproc/asciidoc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= asciidoc
PORTVERSION= 9.0.4
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= https://github.com/asciidoc/asciidoc-py3/releases/download/${PORTVERSION}/
diff --git a/textproc/asciidoc/files/patch-asciidoc.py b/textproc/asciidoc/files/patch-asciidoc.py
new file mode 100644
index 000000000000..f4b0b250bb60
--- /dev/null
+++ b/textproc/asciidoc/files/patch-asciidoc.py
@@ -0,0 +1,13 @@
+Obtained from: https://github.com/asciidoc/asciidoc-py3/commit/8313e45cc78af30bb8df5d33311a7f2fdc50595c
+
+--- asciidoc.py.orig 2020-10-30 15:14:01 UTC
++++ asciidoc.py
+@@ -969,7 +969,7 @@ def system(name, args, is_macro=False, attrs=None):
+ line = subs_attrs(line)
+ if line is not None:
+ result.append(line)
+- result = DEFAULT_NEWLINE.join(result)
++ result = config.newline.join(result)
+ else:
+ assert False
+ if result and name in ('eval3', 'sys3'):